I have recently purchased an Asus X551M laptop and have tried installing Mint in a dual boot configuration multiple times. I have successfully installed it twice, but bot times was unable to actually boot into the OS, or even put it first in the boot priority, as it didn't even show up in the list.

I've decided to try installing Ubuntu 14.04 LTS instead, as I've read it deals with UEFI better. My main barrier though, is that there is absolutely no option to switch to Legacy BIOS on my computer. I can disable boot security and fast boot, and I can turn on CSM. I need Windows for my schoolwork and gaming, so simply overwriting it isn't an option. I'm at my wits end and am about to give up on Linux. Does anyone have any experience with this problem, or any suggestions?

*For both distros I used/am using the 64 bit image. I am using the Universal Usb Installer.

*I've just tried to install 14.04 again. I disabled Secure Boot and put my USB (which was labeled as being UEFI) as the first boot priority. The Ubuntu installer runs fine, but does not detect Windows 8.1. Also, I have 3 partitions as it is, is it true you shouldn't have more than 4?

enter image description here

It is worth noting that if the USB is launched in CSM then Linux detects Windows, installs properly, but does not boot; nor does it become an option in the Boot Priority. If the USB is launched in UEFI mode, then Ubuntu does not detect Windows. Quite the conundrum.

  • 2
    You don't need to enable legacy boot. Disabling Secure Boot and using the amd64 image should be enough. Please edit your question to mention which image you are using, and how you made your bootable device? – muru Oct 22 '14 at 4:26
  • So would I just select the "Do Something Else" option during install and manually create boot, home, and swap partitions? I was hoping I could get away with the letting Ubuntu do all that; I detest manually creating partitions. – Amnesiot Oct 22 '14 at 5:40
  • Can you post a screenshot of the partition screen of the installer? – muru Oct 22 '14 at 5:43
  • I need to be Rep 10 for that :/ – Amnesiot Oct 22 '14 at 5:53
  • onedrive.live.com/… Sorry it took so long, needed sleep. I obviously don't have the installer running, but this is my current partition table. – Amnesiot Oct 22 '14 at 14:36

just disabling secure boot will work just fine

if it doesn't detect windows just shrink your volume however you want via diskmgmt.msc and choose something else within your installation, you can repair your windows boot via boot-repair later on

|improve this answer|||||

To expound on biozalp's answer, I submit this tutorial Dual boot Mint and Windows 8.1

This allowed me to install Mint with no problems.

|improve this answer|||||

I have an Asus X551M too. It was $200 and doesn't even have CD-ROM drive. The key to getting Linux installed was to go into the BIOS setting called OS, and change from Windows 8.1 to Windows 7. Why this is even a BIOS setting is beyond me, a real facepalm moment, but it works, as the Windows 7 setting allows booting from a USB stick. I think the OS option is under Advanced but I'm just working from memory here.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.