1

I'm currently running 14.04 x64, and for the last few days, running either System Updater or apt-get update results in very long wait times (one of the last tries clocked in at over 14 minutes) until the new available packages are ready to be installed (and that's before download even starts).

From what I could tell, it seems that one or more of Canonical repos have either a huge reply time, or just a fantastically slow transfer speed. One of the last "hung" replies seemed to be a particular IPv6 address for security.ubuntu.com (my ISP offers IPv6 networking).

Can anyone provide any insight on what might be going on, and how to make it work swiftly again?

For reference, I'm subscribing to the Portugal main, universe, restricted, and multiverse sources, as well as the following ppas:

  • download.ebz.epson.net/dsc/op/stable/debian/
  • ppa.launchpad.net/oibaf/graphics-drivers/ubuntu
  • ppa.launchpad.net/i-nex-development-team/stable/ubuntu
  • dl.google.com/linux/talkplugin/deb/
  • ppa.launchpad.net/appgrid/stable/ubuntu
  • ppa.launchpad.net/team-xbmc/unstable/ubuntu
  • ppa.launchpad.net/gambas-team/gambas3/ubuntu
  • ppa.launchpad.net/i-nex-development-team/daily/ubuntu
  • download.01.org/gfx/ubuntu/14.04/main
  • ppa.launchpad.net/nilarimogard/webupd8/ubuntu
  • repo.steampowered.com/steam/
  • dl.google.com/linux/chrome/deb/
  • repos.sapo.pt/deb/
  • ppa.launchpad.net/i-nex-development-team/stable/ubuntu
  • ppa.launchpad.net/linrunner/tlp/ubuntu
  • ppa.launchpad.net/webupd8team/java/ubuntu

Hardware-wise, I'm running a basic Intel CPU+mobo combo, no dedicated GPU or any odd piece of kit. Software-wise, it's pretty much standard, AFAIK, except for a couple of Cloud apps (DropBox and CloudPT).

Any help would be very much appreciated.

Thanks in advance for any help you guys can give me.

Michael

P.S.: I'm a Linux newbie, so please don't assume I'll know what you're talking about. My knowledge is fairly limited, I'm still adjusting from Windows.

  • Have you tried selecting a different mirror? askubuntu.com/questions/37753/… – mikewhatever Oct 22 '14 at 0:16
  • Try running sudo apt-get update in a terminal to see what repo is causing your issue. – MoonRunestar Oct 22 '14 at 6:47
  • @Sonickyle21: it seems to vary. I've seen it hang on both "archive.ubuntu.com" and "security.ubuntu.com", this one over IPv6. – nanianmichaels Oct 22 '14 at 8:35
  • @mikewhatever: D'oh. As always, I forget to try the most obvious solution... I'll try the "use best" option, when I get home this afternoon. Hopefully it will clear things up. – nanianmichaels Oct 22 '14 at 8:37
  • @mikewhatever: That did the trick. I tried going the "best server" approach, and everything seems to be working even faster than it was before. Thanks for the help! – nanianmichaels Oct 22 '14 at 20:16
1

The "best server" approach worked good for me also.

Just to make it clear for new users to do this you have to change your etc/apt/sources.list That is shown in the first comment by mikewhatever

Here is the link. How can I get apt to use a mirror close to me, or choose a faster mirror?

Thank you for the help.

  • If you have a NEW question, please ask it by clicking the Ask Question button. If you have sufficient reputation, you may upvote the question. Alternatively, "star" it as a favorite and you will be notified of any new answers. – Tim Jun 28 '15 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.