12

I'm trying to mount my HDD, /dev/sdb, which is connected via an enclosure but every time I try do so I get an error message

mount: /dev/sdb: can't read superblock

How do I solve this problem and mount my HDD?

23

Test this:

Connect your Hdd.

Open a terminal,

Press Ctrl+Alt+T

Run it:

sudo -i
fdisk -l

Suppose that fdisk reports that the partition hdd is /dev/sdb1, continue running:

fsck -y /dev/sdb1
  • 1
    Hello, it didn't detect the HDD. it detected /dev/sda1 on which ubuntu is running instead. – SaeedAwadX Oct 24 '14 at 7:16
  • The drive is likely a goner. Start searching for answers regarding data recovery if you have needed data on the drive. – Elder Geek Mar 16 '15 at 23:31
  • This worked for me. – LEMUEL ADANE Aug 17 '18 at 16:50
  • This worded for me. We Can't have acces to a partition: /dev/sda, but this solved the problem, put in the terminal: fsck -y /dev/sda5 – Indacochea Wachín Nov 4 '18 at 20:26
3

I realise this is an old thread but I will add this just in case it helps someone. I have also had similar problems with and external disk in the past which I think were linked to usb power problems. I got the person I was helping to try the disk in a powered usb hub and this made it visible and mountable. Try that before throwing the disk away as it may be the problem.

2

I had the same issue and solved it with testdisk. Using this info: Advanced FAT Repair | CGSecurity

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.