4

I am trying to play Dota2 and FT2 on my pc when I got this error:

"Could not find OpenGL entry point 'GLGetError'! Either your video card is unsupported or it needs to be updated."

I have spent the last week reading all of the similar questions and have tried some of them (many solutions were to advanced for me to try so I stayed away from them) and I do not know what else to do. If there is any other information needed just ask.

I am using:

  • Ubuntu 14.04 32 bit
  • GLX version is 1.4
  • OpenGL version string: 1.4 Mesa 10.1.3
  • 00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 10) (prog-if 00 [VGA controller])

-

libgl1-mesa-glx:<br>
  Installed: 10.1.3-0ubuntu0.1<br>
  Candidate: 10.1.3-0ubuntu0.1<br>
  Version table:<br>
 *** 10.1.3-0ubuntu0.1 0<br>
        500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main i386 Packages<br>
        100 /var/lib/dpkg/status<br>
     10.1.0-4ubuntu5 0<br>
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main i386 Packages

marked as duplicate by Andrea Corbellini, Mitch Aug 16 '15 at 10:12

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

5

OK! FINALLY. After hours and hours trying to figure out what is going on I got my steam fixed.

Follow these steps and you will be fine. The reason is that steam is trying to use "mesa" drivers and not my ATI Radeon drivers. Stupid steam.

Now:

  1. First close steam.
  2. Then open /etc/ld.so.conf.d/steam.conf for editing:

    sudo nano /etc/ld.so.conf.d/steam.conf
    
  3. In the editor add these two lines:

    /usr/lib32
    /usr/lib32/fglrx/
    
  4. Finally run:

    sudo ldconfig
    

Open Steam. Voila.

I rate if you wish to use the mesa drivers you just have to replace the last line with something like this:

/usr/lib/i386-linux-gnu/mesa

And sorry I don't know what the directories are for GeForce cards but go check in that /usr/lib32 folder for the driver folder for your card and update it where you can locate the libGL.so.1 file. this is what Steam is looking for.

Hope this helps someone else.

This was a fix on Ubuntu 14.04 64bit with Radeon drivers.

  • Still no luck with Nvidia. There's /usr/lib32/nvidia-332 folder which I pointed in steam.conf without results. – s3m3n Mar 25 '15 at 16:16
  • @s3m3n wish I could help you out more. My solution is for Radeon drivers I only assumed that the Nvidia drivers would work the same way. Thanks for letting me know :) – Schalk Mar 26 '15 at 9:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.