Nautilus displays thumbnails very small when I have it set to 200% icon zoom in icon mode. I would prefer to have 5 columns of icons like this, but with larger picture and video icons:

200% zoom

When I set the icon zoom level to 400%, the thumbnail size is better, I only get 2 columns of icons on a 1080p screen!!

400% zoom

Is there any other way to increase the thumbnail sizes to take up proper screen space while keeping at least 5 columns of icons on the screen? To explain, you can see how much the 2nd image is wasting space in nautilus.

2 Answers 2


I have found a very simple solution to this problem.

After a single change, the above folder now looks like this when set to 200% icon zoom level:

200% fixed

It was as simple as changing the "thumbnail-size" value in "dconf-editor" for nautilus to a larger value.

To apply the change, make sure "dconf-editor" is installed in your system by typing the following into a terminal:

sudo apt-get install dconf-editor

After installing, type Alt - F2 to pull up the command dialogue, and type "dconf-editor" to search for it and click on it.

Once you have "dconf-editor" open, navigate to the following location in the left pane:

org > gnome > nautilus > icon-view

See this example image for the location:


The value that needs changed is the "thumbnail-size" value. I changed it from a default of 64 to 128. Depending on your display resolution, you may need to change it to a different value to make things look exactly the way you want. Smaller displays might need a value larger than 64, but 128 might be to large, so try something like 96.

Once that value is changed, exit "dconf-editor". Now the thumbnail cache needs to be cleared to allow that changes to take effect.

First close all Nautilus windows, then type the following code in a terminal (each line is a separate command).

nautilus -q
sudo rm -r ~/.cache/thumbnails/

The first command makes sure Nautilus is closed, and the second clears your thumbnail cache.

Note that this does not affect file or folder icons. Those will still appear to be smaller than the picture and video icons generated by Nautilus (or more correctly generated by ffmpegthumbnailer). This is still a huge improvement for thumbnails in Nautilus even with this shortcoming.

This fix worked on Ubuntu 14.04.1.

  • I do not think the sudo will be necessary in any normal case, and it is always better to avoid it if possible.
    – Arild
    Mar 12, 2015 at 21:17
  • +1 still working on 2020. May 17, 2020 at 9:56
  • 3
    In Ubuntu 20.04 I do not have the 'thumbnail-size' option. And I can't see a way of adding a new option. So I still can't get reasonable images sizes in Files.
    – Henrik R.
    Jul 27, 2021 at 18:36
  • @HenrikR. You still can with the Caja file manager : askubuntu.com/a/1459134/607630 . Hopefully they keep it that way. Mar 13, 2023 at 22:08

The following commands fix the problem without installing additional software. It worked great for me on RHEL 7.2 at least:

dconf write /org/gnome/nautilus/icon-view/thumbnail-size 128
nautilus -q
rm -r ~/.cache/thumbnails/
  • This worked for me today on a clean updated install of CentOS 7 with the gnome desktop, thanks Tormod Landet! Jul 2, 2017 at 15:19
  • This worked for me on Ubuntu 18.04.
    – Asclepius
    Nov 18, 2020 at 16:06
  • 1
    In Ubuntu 20.04 I do not have the 'thumbnail-size' option. And I can't see a way of adding a new option. So I still can't get reasonable images sizes in Files.
    – Henrik R.
    Jul 27, 2021 at 19:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .