When I upgraded to 11.04 Deja Dup started behaving strangely, it would begin a new full backup everytime the computer was started because it was looking for a drive and folder which I had removed some months earlier. Deja Dup had behaved perfectly normal under 10.10, but the upgrade seems to have it using old settings.

So I was wondering how can I purge all the configuration files and folders so that next time I reinstall Deja Dup it starts using and remembering the settings I want? I can not find any folders in /home/username/.config or in the home folder, but on each install something is telling Deja Dup to look at old settings.

Any help would be great!

2 Answers 2


Déjà Dup is the front-end for the duplicity program, Duplicity stores its data in ~/.cache/duplicity. That folder can safely be removed, if you connect with an earlier backup, those files will be recreated from the backup.

Settings for Déjà Dup are stored in dconf. (source: Where is the configuration for dejadup stored?).

To quote Michael Terry:

Hello! The configuration for Deja Dup is stored in dconf, which you can view with dconf-editor (which in Ubuntu is available in the dconf-tools package).

However, to view or edit your saved passwords, you should use the Passwords & Encryption Keys preference utility that comes with GNOME. That stores saved passwords for remote sites as well as the encryption password that Deja Dup saves if you chose to encrypt your backup.

As for system-wide settings, the configuration can be purged by running:

sudo apt-get purge deja-dup
  • I could not find the duplicity folder, ran a search from my home folder and nothing came up. I have run the purge command through terminal and will see how that works next time I restart the PC.
    – KD353
    Jul 22, 2011 at 22:55
  • @Victor: please see the updated answer
    – Lekensteyn
    Jul 22, 2011 at 23:10
  • I have done all the above (but could not find the duplicity folder) and running a back-up now. All the settings in dconf match what I have currently set it to, but when i was setting it up again the non-existent external HDD was still listed as the default local folder. Will leave to back-up and when I next restart will see if it has remembered the settings.
    – KD353
    Jul 23, 2011 at 3:41
  • No, dconf is still remembering the old settings whenever I restart the computer. I have tried resetting everything to 'default' but to no avail. I need to manually input the settings to deja dup everytime the computer is started
    – KD353
    Jul 24, 2011 at 8:18
  • @Victor Try finding files related to dejadup withgrep -Hrnai 'deja' ~ (deja is the search term here, binary files are treated as text).
    – Lekensteyn
    Jul 24, 2011 at 8:23

To reset your deja-dup config you can use the following command on a terminal

From Ubuntu 10.10

dconf reset -f "/org/gnome/deja-dup/"

Until Ubuntu 10.04

gsettings reset-recursively org.gnome.DejaDup
  • You have instructions for up to 10.04, and for 11.04 and later. What to do on 10.10? Jul 10, 2012 at 14:12
  • 1
    Good hint ;-) I was wrong. Dconf was introduced with 10.10. But there is some transition from gconf to dconf so not all software is using dconf right away in 10.10. For details on this see askubuntu.com/questions/91403/when-to-use-gconf-vs-dconf
    – demel
    Oct 17, 2012 at 22:09
  • works for Zorin OS9. I saw someplace else this, and basically it is because this deja dup, does not have the ability to remember the store location. I have a dedicated drive in my system and use it to keep things working smooth. Use of an external drive is fine but may fail because you example plug it into a random USB port, and that will fail because it is not the same address. One thing that confuses me as a Linux noob. I wanted to format this drive to ext4 so that windows wont touch it, as it is only purpose is for Zorin to use it as a backup. However I did all this with Gparted, but the dr
    – user394977
    Apr 4, 2015 at 21:57
  • This still works in Ubuntu 20.04 :)
    – Graipher
    Sep 1, 2020 at 8:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.