This thread suggests pacmd list-sinks and switching to a different sink with pacmd set-default-sink "SINKNAME", but my laptop only appears to have 1 sink, so that didn't help me.

This thread suggests pacmd list-cards which shows hdmi-output-0: HDMI / DisplayPort right at the bottom of the output, and that looks right, but it still says Failure: No such entity when I run pactl set-card-profile 0 output:hdmi-output or pactl set-card-profile 0 output:hdmi-output-0

  • might be better suited as an answer? To the threads that are linked.
    – jmunsch
    Oct 21, 2014 at 13:12
  • 3
    Glad you found a solution and thank you for sharing. You should now write/copy your solution to an own answer and then edit your question to better fit to the Q & A format of this site. Thank you.
    – Takkat
    Oct 21, 2014 at 13:13
  • 1
    Hi James, I've added a community wiki answer below containing your solution. If you later decide you want to post your own answer please come and do that and then we can delete mine. Thanks!
    – Seth
    Oct 24, 2014 at 14:55

2 Answers 2


The OP posted the solution in his question:

While writing this I found the solution:

This command makes it easier to see what my actual output options are:

pacmd list-cards | grep output\:

That way of looking at the output of pacmd list-cards made me realize that the actual wording for my output is not output:hdmi-output but instead output:hdmi-stereo

This command is what worked for me:

pactl set-card-profile 0 output:hdmi-stereo

This is how I switched back to my laptop's internal speakers:

pactl set-card-profile 0 output:analog-stereo

This is how I changed the volume via command line:

amixer -D pulse sset Master 50%

This is just a smiley face:

  • I have two cards. So I changed the 0 to 1 to change the default to analog stereo. May 25, 2020 at 7:02

I just want to specify, that if you have many different outputs, you can find all with

pactl list

For other HDMI output the command is

pactl set-card-profile 0 output:hdmi-stereo-extra1

PS: It's for the HDMI-2 output

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .