1

somewhen in the last few weeks, an updates seems to have made my Brother DCP-195C unusable under Ubuntu 14.04 LTS. USB-Connection is given and the printer does work, but the scanner programs either do not find the scanner at all (e.g. sane) or they find it but cannot access the scanner (e.g. scanimage):

user@host:~$ lsusb | grep Brother
Bus 002 Device 008: ID 04f9:0222 Brother Industries, Ltd 
user@host:~$ dpkg -l | grep Brother
ii  brscan3             0.2.11-4  i386   Brother Scanner Driver
ii  dcp195ccupswrapper  1.1.3-1   i386   Brother CUPS Inkjet Printer Definitions
ii  dcp195clpr          1.1.3-1   i386   Brother lpr Inkjet Printer Definitions
user@host:~$ scanimage -L
device `brother3:bus1;dev1' is a Brother DCP-195C USB scanner
user@host:~$ scanimage -v -p
scanimage: open of device brother3:bus1;dev1 failed: Invalid argument
user@host:~$ sudo scanimage -v -p
[sudo] password for user: 
scanimage: rounded value of br-x from 215.9 to 215.88
scanimage: rounded value of br-y from 355.6 to 355.567
scanimage: output is not a file, exiting
user@host:~$ sudo sane-find-scanner
[...]
  # No USB scanners found. If you expected something different, make sure that
  # you have loaded a kernel driver for your USB host controller and have setup
  # the USB system correctly. See man sane-usb for details.
[...]

The system did work a few weeks ago, so it might be a problem with an update to sane or something similar:

user@host:~$ dpkg -l | grep sane
ii  libsane:i386    1.0.23-3ubuntu3.1   i386  API library for scanners
ii  libsane-common  1.0.23-3ubuntu3.1   i386  API library for scanners -- documentation and support files
ii  libsane-hpaio   3.14.3-0ubuntu3.2   i386  HP SANE backend for multi-function peripherals
ii  sane-utils      1.0.23-3ubuntu3.1   i386  API library for scanners -- utilities
user@host:~$ uname -a
Linux host 3.13.0-37-generic #64-Ubuntu SMP Mon Sep 22 21:30:01 UTC 2014 i686 i686 i686 GNU/Linux

So far I've tried re-installing all drivers after purging the old drivers and downloading the current versions from the brother linux support page, but no luck. Also, it's not a permission problem - the output above is the same if run with elevated privileges.

Any ideas or similar behaviors?


Update: The output of scanimage -T passes correctly and the scan head even starts moving around - still no change in the general problem. I also tried rebooting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.