I have a drive that I would like to install Linux onto, for eventual use on another machine. I want to bring the Ubuntu installer image onto a 20GB partition, and then boot into that.

When I boot onto that partition, I will install the Ubuntu system onto one of the remaining ~500GB partitions of the same hard disk drive.

Using the lsblk command, you can see my current system drive and partition sda1, as well as the 1TB sdb drive that will be the destination system.

mono@mono-Studio-XPS-9100:~$ lsblk
sda      8:0    0 111.8G  0 disk 
├─sda1   8:1    0 103.8G  0 part /
├─sda2   8:2    0     1K  0 part 
└─sda5   8:5    0     8G  0 part [SWAP]
sdb      8:16   0 931.5G  0 disk 
├─sdb1   8:17   0 457.8G  0 part 
├─sdb2   8:18   0 454.2G  0 part 
└─sdb3   8:19   0  19.5G  0 part 

sbd3 is the partition of interest onto which I put the Ubuntu install image.

sudo dd if = 'ubuntukylin-14.04.1-desktop-amd64.iso' of=/dev/sdb3

After executing this dd command, the 20GB sdb3 partition became unmounted. When I rebooted my computer, physically unplugging the sda hard drive, I got a black cursor instead of booting into Linux.

Do I need to do something further?

When I physically re-plugged in the original hard drive and rebooted into my original linux system, the 20GB partition mounted, and inside I have what appears to be the Ubuntu-Kylin 14.04 LTS amd64 system.

UPDATE: I realized that in gparted I could right click the sdab3 partition and change the flags. I selected bootable.

enter image description here enter image description here

Now instead of booting to a cursor, it says `isolinux.bin missing or corrupt. Reboot and select proper Boot device or Insert Boot Media ...'

  • That seems like it's a corrupted file... Try re-downloading Kylin. Also, why can't you just use a USB drive? – Kaz Wolfe Oct 21 '14 at 5:12

Maybe this Link (Ubuntu Live-USB Creation) can help you. It worked fine for me, because I never got it to work manually just with dd, the other tools worked for me just fine :)


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.