0

I have ubuntu 14.04 with pipelight installed. When I try to watch videos on xfinitytv.comcast.net, it says i'm using flash 11.2. When I go to the adobe site, it tells me I'm using 15. Why do some sites think I'm using 11.2 while others think 15?

Update: I thought it might be because it looked at my user agent and knew I was using linux, so I switched it to

Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20131011 Firefox/23.0

but that didn't work either.

  • What browser are you using? – Dan Oct 21 '14 at 0:12
  • I'm using firefox 33. – user2980766 Oct 21 '14 at 0:58
  • you might need to disable the other flash plugin, do you have both listed in plugins? – Mateo Oct 24 '14 at 1:14
  • Yeah, when I disable the 11.2, it disables the pipelight flash, too. – user2980766 Oct 24 '14 at 1:28
2

These are instructions for getting xfinity to work in Linux, without a VM or Playonlinux. Playonlinux was slow and crashed for me. I am sharing these instructions since setting this back up after I upgraded my system took too long.

The solution for xfinity on Linux is Firefox + Pipelight + UA override.

  1. Assume Firefox is installed. No Silverlight in Chromium or Chrome, so that will not work.
  2. Install Pipelight (pipelight.net/cms/installation.html)
  3. Install x64 Flash (assuming you're using a 64 bit machine)

    sudo pipelight-plugin --unlock x64-flash
    sudo pipelight-plugin --enable x64-flash
    
  4. Install Silverlight

    sudo pipelight-plugin --unlock silverlight
    sudo pipelight-plugin --enable silverlight
    
  5. Change to Windows user agent

    Since this is all I will use Firefox for, make the change for everything and permanant. See How to Change Your Browser’s User Agent Without Installing Any Extensions on How-To Geek.

    Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.1

  6. Verify Windows user agent, Silverlight version, Flash version. OS does not matter. Visit this address: http://xfinitytv.comcast.net/computer

  7. Enjoy xfinity on Linux!

0

I used the instructions linked below, and was able to watch xfinity on Ubuntu 14.04 in Firefox by using WINE and the PlayOnLinux (the easy to use front-end for WINE) available at the Ubuntu Software Center:

Cannot Play DRM-protected Flash on Ubuntu 14.10 (Amazon, HBO Go, XFINITY etc), even with Pepper Flash and HAL

I did not need to install Silverlight, but I did install the Adobe Flash add-on, which was available during the installation process for Firefox. Adobe Flash version 15.0 was installed, and that solves the issues of watching xfinity in Firefox on Ubuntu.

I "downloaded" and installed Firefox through the PlayOnLinux front-end when given the "Choose and installation method" option. It is listed when you click on the "Internet" icon. Make sure you DO NOT run Firefox at the end of its installation procedure, i.e Deselect "Launch Firefox now." If you don't deselect it, Firefox won't install properly.

Information and helpful Manual on how to use PlayOnLinux can be found here: https://www.playonlinux.com/en/

When Firefox is installed, it will show up in the PlayOnLinux program window pane. You can then lauch Firefox from there (or the desktop shortcut that may have been installed during the procedure), and enjoy watching xfinity.

Note: I updated from the downloaded FF ver. 31 referenced above, to the latest ver. 34. That caused some problems in the Menu Bar. For some reason, clicking on a menu like "Tools" will display the drop-down menu, but clicking on items within the menu sometimes displays only a partial window, where the other part of the window is black. I have an old computer, so the problem may be related to my system. YMMV

-1

I followed these instructions to replace the 11.2 flash extension with the pipelight flash. It's buggy, but it works.

  • make this as a comment and not as an answer – anand mbs Jun 16 '16 at 3:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.