1

I have ubuntu and I love it but I cannot get my printer to print even though its showing that its installed in the printer screen. I am using 14.04, when ubuntu was first installed on my computer I had 12.0 and a hp printer I had was connected very quickly. Now I have another hp but this time a laserJet pro m127fw and cannot connect it. The printer itself shows that it is not connected to the computer but the computer says otherwise. I have been trying for the past two weeks. I am new to this and feel very stuck. I don't know what else to do at this point. This is my 8th printer. After trying six I was told the other brands does not work with ubuntu, got a brother they said the same. I was told only hp does so I got this one. Someone please HELP

Thanks

  • Have you installed hplip also can you edit your question to include the printer name in the title? – jmunsch Oct 21 '14 at 12:43
1

Please try the below steps which may help,

  • Ping your printers and check whether it was successfull

  • To get started, open Printers utility from Unity Dash search results or System Settings.

  • Once it opens, go to menu Server -> Settings

  • Check the box where it says “Publish shared printers connected to this system” to enable network sharing of connected printers.

  • Finally, right-click on a printer in the list and go to its Properties window. Under Policies tab, make sure all three boxes (Enabled, Accepting jobs, and Shared) are checked.

    Now try to connect to your printer from Ubuntu client using Internet Printing Protocol (ipp://ip.address.or.name/printers/Printername).

If Issue persists, please install CUPS to get rid of it

  1. CUPS is installed right into Ubuntu and Linux Mint and if for some strange reason can’t find it, you can easily install it with the following command.

    sudo apt-get install cups

  2. Now the page would look something like in the image below. As you could have already recognized with the Unity dock on the left, we are running Ubuntu (13.10). You will be able to access CUPS on the same address on Linux Mint, or any other Linux distribution with CUPS as well. Once you are on this page, click on “Administrator”, and then click on “Add Printer.” You might be asked for username and password of your computer.

enter image description here

  1. In the “Add Printer” page, choose the appropriate option – choose local HP Printer (HPIP) or printer or Other Networks Printers or Select Internet Printing Protocol.

enter image description here

In the connection field you will have to enter the IP address of your printer in the format, socket://hostname and hit continue.

It could look something like this, socket://10.33.20.23

  1. In this page you will be asked to give a name, description and location of your machine, you can also choose if you want to share this printer or not with the sharing option. Hit “continue” to go to the next page. In this page you will have to choose your printer manufacturer and subsequently the model and hit “Add printer.” You could find almost all the printers in the list, if you don’t, you will manually have to add the PPD file, which will have all the information required.

enter image description here

  1. At this point you will be able to set the default options and you are in business. Your printer will be ready for use, and whenever you need to print anything you can access your printer from the address

    http://localhost:631

Hope this helps!

| improve this answer | |
0

I've just reinstalled all printers and it worked.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.