0

I just installed the Ubuntu 14.04 and I cant see wireless icon in the panel or any settings related to the wireless icon.

0

Use the following command to list the interfaces,

sudo iwconfig

Please check whether you have installed wireless adapter

To check what drivers your wireless adapter is currently using, you may run the following command:

sudo lshw -C network

lshw lists information on your hardware

-C network filters the output to only show the network class.

In the output, look for the entry with description: Wireless interface and the driver.

Alternatively, you can use the command:

lspci -nnk | grep -A2 0280

lspci lists information on your PCI connected cards

-nnk instructs lspci to output more information about these cards (including the driver being used)

| pipes the output to the next command

grep 0280 filters the output to show lines containing 0280, which is the PCI class code for wireless PCI controllers in Ubuntu.

-A2 shows two more lines of information.

If no driver is installed please follow the below link install Broadcom 802.11 Linux STA driver

1) Depending on your system download 32 or 64 bit package from http://www.broadcom.com/support/802.11/linux_sta.php

2) Go to a terminal to the dir with package.

3) tar -xvzf hybrid-portsrc-.tar.gz Replace version with one you have

4) Install kernel headers (eg. in fedora “yum install kernel-headers”)

5) make -C /lib/modules/uname -r/build M=pwd

if There were no errors

6) Unload Modules from memory rmmod ndiswrapper b43 ssb bcm43xx b43legacy

7) For WPA modprobe ieee80211_crypt_tkip

8)Check if Compiled Module is working insmod wl.ko

Now Probably a new interface will be there for wireless (wlan0 or eth-1) To check it run iwconfig iwlist scanning

AND YES !! ITS Working !!!!!

B)Making it load on boot

1)cp wl.ko /lib/modules/uname-r/kernel/net/wireless/

2)depmod -a

3)rmmod wl

4)modprobe wl

5)Add following Lines to /etc/rc.local (in openSuse /etc/rc/rc.d/boot.local)

Once it is done check whether you can able to see wireless icon.

Hope this helps!

  • Why do you believe he has a Broadcom device? – chili555 Oct 21 '14 at 2:17
  • I am not sure but I think you are asking me to install the wireless driver again? Because right now I just have issue with no wireless icon in the ubuntu panel although i can connect to wireless from settings> Network. Please let me know if there is any possible way to get the wireless icon in the panel so that i have not to go in the settings always for a connection. Thanks :) – Wasif Iqbal Oct 21 '14 at 6:09
0

You can access the driver manager and check if your wireless driver is enabled or not. This obviously depends on your network card, but that's the way I always set up my wireless connection.

  • But internet is working fine right now, the issue is just that I cant see any icon in the ubuntu panel. For now if I have to connect from a connection then i can do this from the settings > network. And there i can see all the available connections. – Wasif Iqbal Oct 21 '14 at 6:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.