0

When I open the browser and I go to localhost in my web-browser, and there is not an index.* file the Apache webserver will show a file browser.

At the end of the file browser, it posts this line:

Apache/2.4.7 (Ubuntu) Server at localhost Port 80

Is there any way to change this message, and if so, where can I find the configuration file that creates this message in Ubuntu 14.04.01?

I have searched on Google for some time but I can't find anything that points me in the correct direction.

Any help would be appreciated.

1 Answer 1

3

First of all set server signature to off, by setting:

ServerTokens ProductOnly
ServerSignature Off

in httpd.conf file. If you want a custom page than use ErrorDocument XXX /path/to/page.html to set different pages. For example: ErrorDocument 403 /error/denied.html

2
  • Thanks but I had to edit the /etc/apache2/apache2.conf file because I can't find the httpd.conf. I added both lines and the message was gone, so I just left the ServerTokens ProductOnly in my config file. I'm happy with the result though, thanks! It also seemed to solve my problem with the virtual hosts, by accident haha! Thank you!
    – rotgers
    Oct 20, 2014 at 11:55
  • The setting is system-wide, so will affect every vhost as well. :)
    – Frantique
    Oct 20, 2014 at 12:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.