0

Ubuntu 12.04.5 LTS (Precise) 32-bit desktop.

I have installed burp (an intercepting Proxy), and it works for programs run from the same computer, but when I try to connect from another computer on the same network, I get "The proxy server is refusing connections" error.

I also tried squid3, but could not get it working: it refuses connections even from the same computer.

How do I set up a proxy on an Ubuntu Precise Desktop system to use it from different computers?

0

Test this:

Open a terminal,

Press Ctrl+Alt+T

Run it:

Install squid:

sudo -i
apt-get update
apt-get install squid3

Configure Squid

sudo -i
nano /etc/squid3/squid.conf

Paste these five lines on file:

auth_param digest program /usr/lib/squid3/digest_pw_auth -c /etc/squid3/passwords
auth_param digest realm proxy
acl authenticated proxy_auth REQUIRED
http_access allow authenticated
http_port 3128

Ctrl + O, save file. Ctrl + X, close nano.

Setting up a users:

sudo -i
htdigest -c /etc/squid3/passwords proxy user01
htdigest  /etc/squid3/passwords proxy user02
htdigest  /etc/squid3/passwords proxy user03

Run Squid:

sudo -i
service squid3 restart

Check who is using a proxy:

sudo -i
tail -f /var/log/squid3/access.log
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.