6

Anyone have suggestions for this:

I upgraded my Ubuntu system to 14.04, and the upgrade failed miserably. I was forced to restart the system in order to get to a login. After following several suggestions on restarting an upgrade, I appear to have a system that is basically working, but I cannot log into the GUI, am forced to CTL+ALT+F1 (or F2-F6) to get a command line login.

Th GUI reaction is to take the first attempt at entering a password, then responds with "Logging in..." directly below the user name that is logging in. That's it, it just sits there. If an attempt to use the mouse changes the name, the message goes away, but the GUI no longer accepts any more passwords.

The clue I have (and am hoping that is not a red-herring) is that the following appears in the /var/log/auth.log (I've removed timestamp, system name and user id):

lightdm: PAM unable to dlopen(pam_kwallet.so):  /lib/security/pam_kwallet.so:  cannot open shared object file: No such file or directory
lightdm: PAM adding faulty module: pam_kwallet.so
lightdm: pam_succeed_if(lightdm:auth): requirement "user ingroup nopasswdlogin" not met by user "userid"

I've tried several update commands, restarts, reboots, and clean-ups. Any suggestions?

3

Looks like pam_kwallet.so is missing. PAM is the authentication module used by lightdm and it wants to load kwallet (I guess that's a KDE keyring) but the library is gone.

If you have access (somehow), try to install the package containing the pam_kwalet.so, or try to configure PAM so that it would not look for this file.

Automatically: try running pam-auth-update and disable KDE wallet (kwallet).

Manually: PAM configuration is in /etc/pam.conf and /etc/pam.d/* -- so grep those for kwallet, (re)move configuration referring to kwallet and retry.

Once you are finished with upgrade then you may want to return the pam-kwallet config, just make sure you have pam_kwallet.so installed.

Looks like Ubuntu bug: https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/1309535

  • 1
    As I feared my log file entry wasn't directly tied to my problem. Your suggestion did, however, speed up my boot-up time. – phk451 Oct 30 '14 at 2:40
1

Ok, this is what I finally had to resort to in order to get past my problem above...

I uninstalled/removed all the GUIs I had on the system (gdm and lightdm). I then reinstalled Unity. I still had a problem, but the login accepted my password, it just went black. From my reading on-line it appears to be potentially a video driver issue. But since I'm using a generic tower system, I was uncertain about the video device, and in my use case I didn't require use of any particular GUI, it just needed to "work".

So, I followed the instructions found at: ubuntu 14.04 freezing up after login and am using one of the alternative GUIs suggested there. Both xubuntu and the Xfce interfaces give me a functional desktop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.