0

I've upgraded my Ubuntu Server from 12.04.3 (or maybe it was .4 - don't really remember) to 14.04 (now it's 14.04.1) some time ago. Didn't need to use munin since then. Now I need it, but all I'm getting is a 404 error while trying to load. Apaches logs show only this:

192.168.1.1 - - [19/Oct/2014:19:41:21 +0200] "GET /munin HTTP/1.1" 404 499 "-" 
"Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) 
Chrome/38.0.2125.104 Safari/537.36"

Can anyone help me to make it work again ? (It worked flawlessly on 12.04)

  • Did you reinstall it since you upgraded? I don't actually know anything about it, but it's not a standard Ubuntu program, I don't think. – Marty Fried Oct 19 '14 at 17:59
  • No I didn't. And that's the last thing I want to do, since I've configured it about 5 years ago, and don't remember now which plugins I've changed and what was changed in them (and it took me a week to get all those customized plugins to work properly). – Szafran Oct 19 '14 at 18:07
2

It appears that the Munin upgrade is borked. It leaves /etc/apache2/conf.d/munin (softlinks to /etc/munin/apache.conf) in the now unused conf.d folder.

Move your softlink into the new folder mv /etc/apache2/conf.d/munin /etc/apache2/conf-enabled/

This will still die, but for another reason. Apache 2.2 -> Apache 2.4 upgrade, which no longer uses Order allow,deny and Allow from .....

Find all the above in /etc/munin/apache.conf and do something like this:

Old values

Order allow,deny
Allow from localhost 127.0.0.0/8 ::1

New values

Require local

If you actually want to access it from some other network, eg, 192.168.0.0/24 then replace it with this:

New values

Require local
Require ip 192.168.0.0/24

That should get you working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.