13

I need to convert a PDF document (tables) to .xls format. So I've read that I need to turn it into text with pdfedit.

I need the steps to install PDFedit on Ubuntu 14.04.

There are some workaround in some forums. I'm not an expert so I'm asking if someone could expose the steps to install a full working PDFedit.

thanks.

  • it works for the text on the PDF. NOT with the tables in the PDF. – miguelmorales85 Oct 19 '14 at 15:06
  • I think nowadays this is not possible anymore. At least not for me. – Phil Roggenbuck Jun 24 '19 at 19:41
21

You can find the pdfedit for Linux at:

http://sharadchhetri.com/2013/12/29/install-pdfedit-for-editing-pdf-file-in-ubuntu/

The current Ubuntu dropped support for the libqt3-mt library. Currently you can add it by editing your /etc/apt/sources.list and adding the lines:

# libqt3-mnt
deb http://old-releases.ubuntu.com/ubuntu lucid main

Then run:

$ sudo apt-get update
$ sudo apt-get install libmng1 libqt3-mt

Now you can install the pdfeditor with (choose either 32b or 64bit):

Install pdfedit (32bit)

$ wget http://us.archive.ubuntu.com/ubuntu/pool/universe/p/pdfedit/pdfedit_0.4.5-2_i386.deb     
$ sudo dpkg -i pdfedit_0.4.5-2_i386.deb

64 bit version:

Download and install pdfedit

$ wget http://us.archive.ubuntu.com/ubuntu/pool/universe/p/pdfedit/pdfedit_0.4.5-2_amd64.deb
$ sudo dpkg -i pdfedit_0.4.5-2_amd64.deb
| improve this answer | |
  • I need to turn the PDF into a editable format. pdfmod will not help me with that. – miguelmorales85 Oct 19 '14 at 13:35
  • @miguelmorales85 Sorry. I updated my answer. If you already have the file, please advise the errors you're getting. – L. D. James Oct 19 '14 at 13:39
  • Im using 64 bits. this is the error: Selecting previously unselected package libqt3-mt. (Reading database ... 330477 files and directories currently installed.) Preparing to unpack libqt3-mt_3.3.8-b-8ubuntu3_amd64.deb ... Unpacking libqt3-mt (3:3.3.8-b-8ubuntu3) ... dpkg: dependency problems prevent configuration of libqt3-mt: libqt3-mt depends on libmng1 (>= 1.0.10); however: Package libmng1 is not installed. dpkg: error processing package libqt3-mt (--install): dependency problems - leaving unconfigured Errors were encountered while processing: libqt3-mt – miguelmorales85 Oct 19 '14 at 13:54
  • 1
    @miguelmorales85 Glad it works. I'll recommend that you clean up your packages with $ sudo apt-get install -f. When you execute that, it might remove pdfedit. You can have a cleaner install with with the updated steps with uses the libqt3-mt dependency from Ubuntu. Enjoy! – L. D. James Oct 19 '14 at 15:12
  • 1
    I get an error: W: GPG error: http://old-releases.ubuntu.com/ubuntu lucid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 40976EAF437D05B5 E: The repository 'http://old-releases.ubuntu.com/ubuntu lucid Release' is not signed. – Xerus Oct 2 '18 at 8:33
1

Thank you for the great help!

Just a little change to apply since Lucid archive moved:

#libqt3-mnt
deb http://cz.archive.ubuntu.com/ubuntu lucid main

Replace cz.archive with old-releases

#libqt3-mnt 
deb http://old-releases.ubuntu.com/ubuntu lucid main
| improve this answer | |
0

Fast solution

Download

wget http://mirrors.kernel.org/ubuntu/pool/main/libm/libmng/libmng1_1.0.10-3_amd64.deb
wget http://us.archive.ubuntu.com/ubuntu/pool/main/q/qt-x11-free/libqt3-mt_3.3.8-b-8ubuntu3_amd64.deb
wget http://us.archive.ubuntu.com/ubuntu/pool/universe/p/pdfedit/pdfedit_0.4.5-2_amd64.deb

Then Install

sudo dpkg -i libmng1_1.0.10-3_amd64.deb
sudo dpkg -i libqt3-mt_3.3.8-b-8ubuntu3_amd64.deb
sudo dpkg -i pdfedit_0.4.5-2_amd64.deb

Note: It worked on Ubuntu 14.04.5 LTS, evenif pdfedit sometimes crashes...
Reference


Whole story

The program pdfedit seems to be few (or not) maintained nowadays.

One (hard) way should be to pass through the source code, following the path given by the site you will finish to the sourgeforce repository, always useful to take the code, but not updated almost 7 years (from 2010-05-11).

Downloading the source code, ./configure will probably throw you the error

configure: error: QTDIR environment variable must Be Set

and you will finish before or after to incur in the need to install qt3 and specifically libqt3-mt. Note that libqt3-mt needs libmng1 too.

So you can as suggested by another answer the old repositories
deb http://old-releases.ubuntu.com/ubuntu lucid main
to your
/etc/apt/sources.list

or you can use the fast solution since even the support for the libqt3-mt and libmng1 libraries are dropped.

| improve this answer | |
  • 1
    Can't install libmng: dpkg: dependency problems prevent configuration of libmng1:amd64: libmng1:amd64 depends on liblcms1 (>= 1.15-1); however: Package liblcms1 is not installed. – Xerus Oct 2 '18 at 8:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.