12

There was a Garamond font in my Libre Office a few days back. When trying to solve another issue (long story) I downloaded a couple of ttf files and installed them. They look awful, so I want to go back. But now I can't find them. I installed font manager and it shows me lots of fonts but not actually Garamond. Libre Office shows just one Garamond, though I loaded two. I loaded them with font viewer. I looked in my ~/.fonts, /usr/local/share/fonts/, /usr/share/fonts but no Garamonds there so I don't know where LibreOffice is finding the Garamond it is showing me. It occurs to me that it might be a substituted font, provided because I have existing documents that use Garamond. I don't know how to check if this is true. Does anyone know where that Garamond is actually coming from?

Update: I used gedit to look at the list of fonts and found there are two fonts called Garamond. I don't know if LibreOffice is using one of those, but I expect it is. However I also don't yet know how to remove both of them and reinstall what I had before. But this doesn't now look like a LibreOffice issue, except that it is (quite reasonably) presenting just one font when there are two of the same name.

  • I also noticed that OpenOffice had fonts I could not see in other tools. There is this one /usr/share/fonts/truetype/openoffice/opens___.ttf, but that's not Garamond... – Alexis Wilke Oct 19 '14 at 0:46
  • Isn't that just the OpenSymbol font? Actually I just tried using gedit to look at the list of fonts and Garamond is there, twice. Neither of them looks good though. That means it isn't a LibreOffice issue I think, but I still don't know where those Garamonds are held, nor how to remove them (I've edited the question in light of this, though). – RogerParkinson Oct 19 '14 at 3:26
  • "I just tried using gedit to look at the list of fonts", What 'list' exactly did you open in gedit? You make not much sense. – mondjunge Nov 3 '16 at 10:09
  • @mondjunge gedit allows you to change font and displays a selection of fonts available. This is the list I referred to. – RogerParkinson May 5 '17 at 23:49
1

You can find the answer to your problem in this link. You should check what is the default font that is used in case of a missing font. Then change your text to use that font. If nothing changes, it means Garamond is not installed on your machine. If it does change, then what you were seeing is Garamond.

Edited: Thanks to muru

Apparently, Garamond font is not free. So, most probably you don't have the font on your system. Note, that the substitution is done by LibreOffice and not the Ubuntu itself.

In LibreOffice go to Tools > Options ..., select the section Fonts. You should be able to see what font is being used in case a font is not found.

0

I've been using different distros of Linux for about five years now but I still come back to Ubuntu. I'm also still attached to Micro$oft on my dual-boot laptop. Even after using WINE, I still can't get away from M$.

One of the great pleasures I find when using Ubuntu or any other flavor of Linux, is that I can still access and utilize the Window$ partition of the hard drive. I'm not yet accustomed to using LibreOffice and still rely on Micro$oft Office.

Garamond has been included as a free font with M$ Office since its 2000 version. I have been able to install many of my fonts from M$ to Ubuntu. I crossed over to the Window$ partition, opened the Win. folder, opened the fonts folder, and installed a majority of the fonts.

Of course this means one has to have access to Micro$oft Office and its fonts.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.