9

I have a problem in the way text appears in GIMP, I think its related to hinting or anti-aliasing but I have no idea about the cause nor the solution for it.

enter image description here

0
18

There is a workaround is available to this problem. Just turn off the anti-aliasing. But the font look very ugly if we turn off that.

Another Solution is just create a file in

sudo gedit /etc/gimp/2.0/fonts.conf

Paste the lines

<fontconfig>
 <match target="font">
  <edit name="rgba" mode="assign">
   <const>none</const>
  </edit>
 </match>
</fontconfig>

Save and Close the editor.

You can find the details in http://smashingweb.info/solved-green-border-around-gimp-text/

Just try this Dont know whether it will work or not.

3
  • 2
    ~/.gimp-2.8/fonts.conf works as well
    – ustick
    Apr 26 '18 at 10:48
  • Yes. In Gimp 2.8 it works perfect. Jun 15 '18 at 23:30
  • After create the conf file, close and re-open GIMP, you have to edit the text to see the green border go away. Mar 21 '19 at 10:50
0

Yes, "anti-aliasing" problem.

Look at the image format, it needs to be set to RGB. It's probably a 256 color palette now. The menu is:

Image » Mode » RGB

Note that at the time you save your image you can convert it back to a paletted image. However, you may again lose quality. Also make sure to keep a .xcf version of the file (Gimp's format) so that way you can do further edits later.

1
  • The color mode is already RGB.. :/ Oct 19 '14 at 0:57
0

In my case I had a file with ready text layers. And after adding a fonts.conf file and closing Gimp and reopening the file, green borders around text were still there. I found out that to make text look good, I need to disable and enable the anti-aliasing for each text layer. Hope this helps someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.