0

I just finished following this tutorial to set up a postfix mail server on ubuntu 14.04:

https://www.digitalocean.com/community/tutorials/how-to-install-and-setup-postfix-on-ubuntu-14-04

When I tried sending an email to root@example.com from Gmail, nothing shows up in /var/mail. There is no file there. But when I send an email from root@example.com to the Gmail account, the email sends fine.

The tutorial doesn't go in-depth enough to know what's going wrong so I was hoping I could get an answer here.

  • 1
    Postfix may, by default, squash external email sent to root. root may receive mail from internal services. (I just tried this with my server and the mail was received but did not appear in the mailbox for root.) Can you try by sending to another user? Also, use mxtoolbox.com to check your domain MX and SMTP functionality - you'll see pretty quickly if the problem is related to your Postfix config or issues with your domain DNS setup. – douggro Oct 18 '14 at 21:52
0

Are you certain that inbound SMTP traffic is reaching your server? Many ISPs in the United States block such traffic.

Use nmap or netcat to see whether your machine is reachable from the inner layers outward: first on the lan, then from outside your firewall (e.g. a wireless connection to your gateway) and then from a remote site.

When you receive the error message from Gmail, the actual error will go a long way to diagnose the problem.

| improve this answer | |
  • Your base answer is on-track, but working from the outside first will be quicker to determine the problem. Routing is different internally on a LAN and services that are open to the local net may not be reachable externally as you pointed out for the case of SMTP traffic on port 25. – douggro Oct 18 '14 at 21:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.