I have a login problem with a game (league of legends - the login server did not respond).I found somewhere that I need to install lib32-gnutls to fix this problem, but I don't know how to do this.

I downloaded the files from here: https://www.archlinux.org/packages/multilib/x86_64/lib32-gnutls/

Inside the folder lib32-gnutls are these files:

libgnutls-openssl.so         libgnutls.so.28            libgnutlsxx.so.28.1.0
libgnutls-openssl.so.27      libgnutls.so.28.41.0  pkgconfig
libgnutls-openssl.so.27.0.2  libgnutlsxx.so
libgnutls.so                 libgnutlsxx.so.28

I tried to install them through terminal with:

sudo apt-get install 'the name of the file'

but I get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
W: Duplicate sources.list entry http://dl.google.com/linux/chrome/deb/ stable/main i386 Packages (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-i386_Packages)
W: You may want to run apt-get update to correct these problems
E: Unable to locate package libgnutls.so.28
E: Couldn't find any package by regex 'libgnutls.so.28'    

I have ran the command apt-get update.

So what should I do next?


1 Answer 1


I had the same problem and solved with this: basically you have to open playonlinux, choose right click League of legends -> Registry editor and then delete:

  • 1
    -1 This answer is unrelated because it's about Wine DLL overrides and not the installation of Linux-native 32-bit libraries like the question. Feb 18, 2016 at 23:01
  • @DavidFoerster maybe this is outdated now but as far as it isn't a direct response to the inquiry it DID solve the same issue in my case. There is no real reason to downvote since there no other answers to this issue BECAUSE the simple installation can lead to this error and this is solved by deleteing those registry entries.
    – Leggy7
    Feb 19, 2016 at 10:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.