0

My host OS crashed while my Xubuntu VM was updating things. After restarting and loading up the VM, I was greeted with a blank grey desktop and nothing to click on. Luckily, I could still get to a terminal with the keyboard.

With some googling I figured out that I had lost the xfce4-panel and xfdesktop packages, which I reinstalled using apt, getting back my panels and desktop background and icons, respectively.

I've just tried to launch one of my desktop shortcuts, and discovered that they don't work, it seems that I'm also missing thunar. I'm just about to reinstall that, but I'm beginning to wonder what other weird problems I'm going to run into, and how on earth I'll figure out what packages I need to reinstall to fix them.

I've already tried apt-get update, apt-get upgrade, and dpkg --configure -a as per this answer, but they didn't seem to do much. Is there an easy way to figure out what I need to reinstall, or even just to reinstall all the xfce-related things, as that seems to be what's missing?

My virtual machine application supports guest OS snapshots, but I don't have any.

  • Try reinstalling xubuntu-desktop. – To Do Oct 18 '14 at 14:30
  • @ToDo That seems to have installed a whole bunch of xfce4- packages, which seems like what I needed. If you add that as an answer I'll accept it. – Cam Jackson Oct 18 '14 at 23:36
1

If you install xubuntu-desktop, you will proabably recover most of what you lost.

sudo apt-get install xubuntu-desktop

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.