12

I have a laptop HP-Pavilion-g (1246-ef) running in dual boot Windows and Xubuntu. In Windows I can use its special area (a small dip) in the upper left corner of the touchpad to disable / enable on double click. A small red light is seen when disabled.

enter image description here

Can I activate this feature in Ubuntu? I do not want a workaround. I want a solution to get that working without scripts and commands.

(I am not talking about How to quickly enable/disable touchpad in Xubuntu - that I know.)

(A funny thing: when I disable the touchpad in Windows and then restart in Ubuntu the touchpad cannot be enabled and is not seen as disabled in Ubuntu. But if I shut down completely (shut down, not restart) and boot in Ubuntu, this setting is reset and the touchpad is active. But maybe this has not much to do with the above question)

(X)ubuntu 14.04 3.13.0-39-generic


NOTE that this question is aiming exclusively at using in X(ubuntu) the hardware option that the laptop has (that is the 'dip', that button), and NOT at finding a workaround, a terminal command or a software option to disable the touchpad.

  • 1
    Can you try running udevadm monitor then doing your double click on the touchpad? – CameronNemo Nov 9 '14 at 2:20
  • 1
    @CameronNemo got nothing from it. – RolandiXor Nov 9 '14 at 4:16
  • 1
    similar or the same question? askubuntu.com/questions/83590/… – fossfreedom Nov 9 '14 at 21:06
  • 1
    Can you please give the exact model number of the laptop? – Jan Nov 10 '14 at 9:27
  • 2
    @cipricus the answer is no, but only for now. – RolandiXor Nov 16 '14 at 22:53
6
+500

You should report this as a bug. The best place to report this is the xserver-xorg-input-synaptics package (FreeDesktop Bugs). See this question for good bug reporting guidelines. You can also post the bug link here, and I will update its status periodically. I have placed a workaround down below in case you want to try an alternate solution. Please note that you will be reporting a bug to the FreeDesktop system. After logging in, choose report a bug. Report the bug against the Xorg package. When prompted for the component, make sure to select input/synaptics. Fill in any other specific information that is needed.

Bug Tracker for ID NaN

Status: Lookup Error 3
Importance: Lookup Error 3
Assigned To: Lookup Error 3

(Link to Bug)


In a short answer, this is not possible because there are no Linux drivers that do this. (Report a bug to possibly get one!)

This touchpad works by having that dipped area be its own button. When it is double-tapped, the Windows driver says "Hey, I should disable/enable the touchpad!". It then sends the disable or enable message to the touchpad, settings its state.

When you reboot, power to the touchpad isn't lost. So, whatever state it was in is kept. When you fully shut down, power is lost, so the state is reset.

AFAIK, there is no method to do this with that dip, at least kernel-wise. You may be able to write your own driver, but that is beyond the scope of this question (and possibly even this site).

You may be able to do a little workaround, which goes like this:

  1. First off, find your touchpad in xinput-list. Remeber the ID.
  2. Save this into /usr/bin:

    #!/bin/bash
    
    if [ -e /tmp/mouse-disabled ]; then
      rm -f /tmp/mouse-disabled
      xinput enable [id]
    else
      touch /tmp/mouse-disabled
      xinput disable [id]
    fi;
  3. Replace all instances with ID with your proper id.

  4. Create a Keyboard Shortcut. Make this the program to be run, and assign any keybind you want. I used Win+Ctrl+T for a while.

(Sourced from most posts here and this post.)

  • 3
    In place of "xinput set-prop 'Device Enabled' [1 | 0]" you could use xinput [enable | disable] <ID>. Anyway, OP specifically said no workaround! Laptops already have a Fn key shortcut for doing this. – Sri Nov 13 '14 at 3:05
  • @sri AFAIK, there is no non-workaround way to do this. It may be possible to detect when a certain area of the touchpad is double-tapped, and disable the touchpad that way, but that is beyond my scope of ability. – Kaz Wolfe Nov 13 '14 at 5:23
  • 2
    Can someone please explain their downvote? There is no real solution for this. I know the OP asked for a non-workaround, but the only way to get this to work is a workaround... – Kaz Wolfe Nov 13 '14 at 7:21
  • @sri Also this model laptop does not have a F-key for this. It uses that little dip button. – Kaz Wolfe Nov 13 '14 at 7:22
  • workarounds have nothing to do here. see linked question with the answer that works. please specify more clearly why this is not possible: no drivers! - that is the real answer and that I shall mark as definitive if the case – user47206 Nov 15 '14 at 18:52
0

I recommend touchpad indicator, its awesome, tons of functionality!

sudo add-apt-repository ppa:atareao/atareao    
sudo apt-get update    
sudo apt-get install touchpad-indicator
  • Use it and you will find out, you can enable and disable manually. – WhosUrDaddy Nov 13 '14 at 9:22
  • have you not noticed my remark in the question? (-- I am not talking about How to quickly enable/disable touchpad in Xubuntu--): this question is strictly limited to using in X(ubuntu) the hardware option that the laptop has – user47206 Nov 15 '14 at 18:49
  • xubuntu already has its own mouse/touchpad application, no need for a new one. but i already have that anyway, beside the Xubuntu one, and mainly i use the answer from the linked question that i created myself: launchers with 'xinput set-prop 15 "Device Enabled" 0' or '1'. i have asked the present question just for that button, for the rest i do have a solution. your answer fits better the other question – user47206 Nov 15 '14 at 18:57
-2

Ok let me give you the exact closet solution to your question, since it seems there are not many touchpad tweak tools.

Commands to enable or disable touchpad:

Enable touchpad:

xinput --set-prop 'FSPPS/2 Sentelic FingerSensingPad' 'Device Enabled' 1


Disable touchpad:

xinput --set-prop 'FSPPS/2 Sentelic FingerSensingPad' 'Device Enabled' 0

The parameter 'FSPPS/2 Sentelic FingerSensingPad' is the device name for my touchpad.

You can find your own device name by using this command:

xinput --list


You want to install CCSM. Command:

sudo apt-get install compizconfig-settings-manager

Open it from the main menu.

Click on the 'commands' option

Input the disable touchpad command on the line you want and assign the key/button/edge binding you want to use to disable the touchpad.

That's the best workaround I can give right now. I'll see if I can find something better.

  • 3
    Let's keep our comments civil. Civility is required at all times. – Seth Nov 17 '14 at 1:39
  • 2
    your second answer provides useful information. only this usefulness is limited, as i said in a comment to your first answer: i have already linked to a question that i posted and answered myself, containing mainly the same stuff. when i did that, i looked around on askubuntu to see whether other people have provided already that same info: and they did HERE. your "exact closest solution" is one that i have anticipated and explicitly advised against (because I already had it!). – user47206 Nov 17 '14 at 8:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy