0

Since installing Xubuntu 14.04 the microphone has not worked either on my Laptop or Desktop installations. This is a system wide issue not confined to SKYPE.

Testing I have performed thus far:

  • Volume control

    Not muted.

  • Volume control > Recording

    While on Skype test call, the mic level does not move and there is no input devices showing.

  • Skype

    Unselected 'Allow Skype to automatically adjust mixer levels'.

  • ~$ arecord -d 10 /tmp/test-mic.wav

    Plays back interference noise only.

  • ~$ sudo aplay -l

    **** List of PLAYBACK Hardware Devices **** card 0: MID [HDA Intel MID], device 0: CX20585 Analog [CX20585 Analog] Subdevices: 0/1 Subdevice #0: subdevice #0 card 0: MID [HDA Intel MID], device 3: HDMI 0 [HDMI 0] Subdevices: 1/1 Subdevice #0: subdevice #0

  • Volume Levels

    Unable to locate 'System->Preferences->Sound' in Settings, does not seem to exist?

  • Alsamixer settings

    I Do not see 'Mic' tab only 'Mic Boost' tab? I tried increaing the 'Internal Mic Boost' level and disabling 'Auto-Mute Mode' but no change.

    enter image description here

Edit:

Add additional drivers

  • Installed latest driver for my Nvidia graphics card
  • Confirmed that drivers are in use lspci -vnn | grep -i VGA -A 12 Kernel driver in use: nvidia
  • Checked hardware acceleration Quadro FX 1700/PCIe/SSE2

Further Alsamixer testing

  • aplay -lL

default Playback/recording through the PulseAudio sound server null Discard all samples (playback) or generate zero samples (capture) pulse PulseAudio Sound Server sysdefault:CARD=Intel HDA Intel, AD1988 Analog Default Audio Device front:CARD=Intel,DEV=0 HDA Intel, AD1988 Analog Front speakers surround40:CARD=Intel,DEV=0 HDA Intel, AD1988 Analog 4.0 Surround output to Front and Rear speakers surround41:CARD=Intel,DEV=0 HDA Intel, AD1988 Analog 4.1 Surround output to Front, Rear and Subwoofer speakers surround50:CARD=Intel,DEV=0 HDA Intel, AD1988 Analog 5.0 Surround output to Front, Center and Rear speakers surround51:CARD=Intel,DEV=0 HDA Intel, AD1988 Analog 5.1 Surround output to Front, Center, Rear and Subwoofer speakers surround71:CARD=Intel,DEV=0 HDA Intel, AD1988 Analog 7.1 Surround output to Front, Center, Side, Rear and Woofer speakers iec958:CARD=Intel,DEV=0 HDA Intel, AD1988 Digital IEC958 (S/PDIF) Digital Audio Output **** List of PLAYBACK Hardware Devices **** card 0: Intel [HDA Intel], device 0: AD1988 Analog [AD1988 Analog] Subdevices: 0/1 Subdevice #0: subdevice #0 card 0: Intel [HDA Intel], device 1: AD1988 Digital [AD1988 Digital] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: Intel [HDA Intel], device 2: AD1988 Alt Analog [AD1988 Alt Analog] Subdevices: 1/1 Subdevice #0: subdevice #0

  • F6: Select sound card: nvidia/nvidia-340

Error Cannot Can not open mixer device 'nvidia'. No such file or directory

LSPCI

  • lspci -nn | grep -i audio

00:1b.0 Audio device [0403]: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller [8086:3a3e]

  • lspci

03:00.0 VGA compatible controller: NVIDIA Corporation G84GL [Quadro FX 1700] (rev a1)

Thanks for any help in advance!

1

In alsamixer, press F4 to get to the mic settings, and disable this "Auto-mute" thing I see on screenshot too.
And the main thing is - use pavucontrol instead of alsamixer and stop reading that 10-year-old manual you have found all this things in. Pulseaudio overrides and essentially deprecates all this stuff.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.