0

Lately I tried changing the colour theme of my Eclipse Luna to dark. Then I decided to revert back to the default GTK theme. But after I have done so, the title on the active edit window is missing (or are the same colour as that of it's background, I'm not sure). I tried editing the colours from the Preferences but as soon as I close the Preferences window, the title goes missing again.

Here are some screen shots to help you get a better picture of what is happening.

When the Preference window is opened When the Preferences window is closed

This gets especially annoying since I can't see whether the current file has been saved or not until I switch to a different tab.

I tried the obvious restart procedures with no effect, in case you are wondering.

Note: I am working on Ubuntu 14.04 GNOME 3.8.4.

EDIT:

I tried changing the colour of every element in the list provided both from the eclipse directory via a text editor as well as the eclipse UI but the most I could achieve was change the background colour of the title, but not the text colour itself. Which exact key contains the value for the active title text colour?

Finally, the thing is, when I tried changing the colour of each field, if it did not work I reset the changes then and there. But weirdly enough, when I hit the reset button, eclipse somehow changes the foreground colour to white. I don't know why or how. But I have finally fixed this.

Conclusion

For those of you facing the same problem. Just go to Window -> Preferences -> General -> Appearance -> Colors and Fonts -> Click on Active part foreground -> Manually set it to whatever colour you want. -> Hit apply.(Do not try resetting. Doesn't work)

On later inspection I have found out that this has been caused due to me changing the GNOME Theme to Dark causing the title to be somehow automatically changed to white to accommodate for a dark background; however that is not the case here(well, GNOME was expecting it I think).

1
+50

Might be something in the theme css file, check ${ECLIPSE_HOME}/plugins/org.eclipse.ui.themes_X.Y.Z/css/e4_default_gtk.css

There are settings such as ColorDefinition#org-eclipse-ui-workbench-ACTIVE_TAB_OUTLINE_COLOR

It's the only thing i can think of that might cause this.

  • Right now, the field you have suggested appears to be on #B6BCCC which should stand out on a presumably #FFFFFF background. But it doesn't! – shyam Oct 22 '14 at 12:31
  • +1 Thank you. Helped me find the actual solution. – shyam Oct 24 '14 at 6:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.