3

The behaviour I see after running sudo hibernate-disk -v4 is a bunch of output, followed by a switch to console, which prints a few lines, ending with "Preallocating image memory..." and then a switch back to the X11 VT, and the computer resumes running normally.

Here is stdout:

hibernate-disk: Using implicit configuration file /etc/hibernate/disk.conf
hibernate-disk:Warning: Tuxonice binary signature file not found.
hibernate-disk: Trying method in ususpend-disk.conf...
hibernate-disk: Including configuration from common.conf
hibernate-disk: [01] Executing CheckLastResume ...
hibernate-disk: [01] Executing CheckRunlevel ...
hibernate-disk: [01] Executing LockFileGet ...
hibernate-disk: [01] Executing NewKernelFileCheck ...
hibernate-disk: [10] Executing EnsureUSuspendCapable ...
hibernate-disk: [11] Executing XHacksSuspendHook1 ...
hibernate-disk: [59] Executing RemountXFSBootRO ...
hibernate-disk: [89] Executing SaveKernelModprobe ...
Saved /proc/sys/kernel/modprobe is /sbin/modprobe
hibernate-disk: [91] Executing ModulesUnloadBlacklist ...
Unloading blacklisted modules listed /etc/hibernate/blacklisted-modules
Module version for ipw2100 is 2
Module version for ipw2200 is 2
Module version for snd_bt_sco is
Module version for ndiswrapper is
Unloading blacklisted module mac80211 (and dependencies)
Unloading rtl8723ae ...
Removing modules with rmmod.
Unloading rtl_pci ...
Unloading rtlwifi ...
Unloading mac80211 ...
hibernate-disk: [95] Executing XHacksSuspendHook2 ...
xhacks: changing console from 7 to 15
hibernate-disk: [98] Executing CheckRunlevel ...
hibernate-disk: [99] Executing DoUSuspend ...
hibernate-disk: Running /usr/sbin/s2disk ...
hibernate-disk: [90] Executing ModulesLoad ...
Loading module rtl8723ae (from auto)...
Loading module rtl_pci (from auto)...
Loading module rtlwifi (from auto)...
Loading module mac80211 (from auto)...
hibernate-disk: [89] Executing RestoreKernelModprobe ...
hibernate-disk: [85] Executing XHacksResumeHook2 ...
xhacks: changing console back to 7
hibernate-disk: [70] Executing ClockRestore ...
hibernate-disk: [59] Executing RemountXFSBootRW ...
hibernate-disk: [11] Executing XHacksResumeHook1 ...
hibernate-disk: [01] Executing NoteLastResume ...
hibernate-disk: [01] Executing LockFilePut ...

Here is stdout and stderr together (big): http://pastebin.com/AWDt5xZn

And here is dmesg output during the hibernation:

[196345.773202] wlan1: deauthenticating from c8:d7:19:8c:78:9f by local choice (reason=3)
[196345.839413] cfg80211: Calling CRDA to update world regulatory domain
[196345.845045] cfg80211: World regulatory domain updated:
[196345.845053] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[196345.845057] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[196345.845088] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[196345.845092] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[196345.845095] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[196345.845099] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[196346.158150] Syncing filesystems ... done.
[196346.165319] Freezing user space processes ... (elapsed 0.002 seconds) done.
[196346.167703] PM: Marking nosave pages: [mem 0x0009d000-0x000fffff]
[196346.167741] PM: Marking nosave pages: [mem 0xcaee2000-0xcaee8fff]
[196346.167775] PM: Marking nosave pages: [mem 0xcb6a8000-0xcb919fff]
[196346.167821] PM: Marking nosave pages: [mem 0xdb2d1000-0xdb358fff]
[196346.167856] PM: Marking nosave pages: [mem 0xdb4b6000-0xdbffefff]
[196346.167945] PM: Marking nosave pages: [mem 0xdc000000-0xffffffff]
[196346.168625] PM: Basic memory bitmaps created
[196346.168688] PM: Preallocating image memory... 
[196356.699599] PM: Basic memory bitmaps freed
[196356.699620] Restarting tasks ... done.
[196356.715564] video LNXVIDEO:00: Restoring backlight state
[196356.876309] rtl8723ae: Using firmware rtlwifi/rtl8723fw_B.bin
[196356.883980] ieee80211 phy13: Selected rate control algorithm 'rtl_rc'
[196356.884220] rtlwifi: wireless switch is on
[196356.919095] systemd-udevd[26647]: renamed network interface wlan0 to wlan1
[196357.323242] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
[196357.324443] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
[196358.397233] wlan1: authenticate with c8:d7:19:8c:78:9f
[196358.413738] wlan1: send auth to c8:d7:19:8c:78:9f (try 1/3)
[196358.416989] wlan1: authenticated
[196358.418088] wlan1: associate with c8:d7:19:8c:78:9f (try 1/3)
[196358.421525] wlan1: RX AssocResp from c8:d7:19:8c:78:9f (capab=0x411 status=0 aid=4)
[196358.421844] wlan1: associated
[196358.421914] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready

Any ideas? Not sure where to go from here.

  • Have you read this page? Also, it might be worth trying pm-hibernate. That used to work for me occasionally, but I think hibernation is pretty flakey at best. – Sparhawk Oct 23 '14 at 0:53
  • I swear Ubuntu dropped support for hibernate a long time ago. So whatever is there is a YMMV experience. – ppetraki Oct 24 '14 at 16:24
1

I've seen messages here and there about hibernation on Ubuntu/Linux in general not being well supported, and being a low priority for the Ubuntu kernel team.

I recommend trying out alternatives, like the tuxonice patches. There is a ppa for tuxonice here: https://launchpad.net/~tuxonice/+archive/ubuntu/ppa

Tuxonice is a set of kernel patches which provides an alternative method of hibernation than what comes with the stock kernel. I had a success in the past with tuxonice, so it's worth a shot. Good luck!

| improve this answer | |
1

The Linux kernel documentation has a debug procedure for suspend/hibernation issues.

You should read the full document, but the gist of it is... You should iteratively try the test modes of hiberation—freezer, devices, platform, processors and core— starting with the least invasive (freezer) and going up to the most invasive (core).

# echo <test mode> > /sys/power/pm_test
# echo platform > /sys/power/disk
# echo disk > /sys/power/state

I suspect from your logs that the problem might be related to ACPI—it seems that everything works up to the moment that the CPU must be suspended—and, if so, it probably can be solved adding some kernel command line options.

| improve this answer | |
0

I don't have hibernate-disk installed, but you could try to hibernate system like this:

echo disk > /sys/power/state 

or you could suspend to low power mode (S3), sleep on windows with this:

echo mem > /sys/power/state 

maybe you have to be sudo before ..

hope that helps,,

cheers, k

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.