6

The bug is described here: https://bugs.kde.org/show_bug.cgi?id=339174 For me it fails with:

java: /build/buildd/oxygen-gtk3-1.0.2/src/animations/oxygencomboboxdata.cpp:87: void Oxygen::ComboBoxData::setButton(GtkWidget*): Assertion `!_button._widget' failed.

Problem is if I go to GTK+ Apperance in Control Module and change to anything other than oxygen Eclipse will look totally awful.

Regardless what theme I use (tried QtCurve and Raleigh) it has the same look with huge padding around all controls etc.

Is it possible to have a sensible look without oxygen GTK?

I have kubuntu-desktop installed over the stock LTS distro.

 $dpkg -l libgtk* | grep -e '^i' | grep -e 'libgtk-*[0-9]'
    ii  libgtk-3-0                             3.4.2-0ubuntu0.8                          GTK+ graphical user interface library
    ii  libgtk-3-bin                           3.4.2-0ubuntu0.8                          programs for the GTK+ graphical user interface library
    ii  libgtk-3-common                        3.4.2-0ubuntu0.8                          common files for the GTK+ graphical user interface library
    ii  libgtk2.0-0                            2.24.10-0ubuntu6.1                        GTK+ graphical user interface library
    ii  libgtk2.0-bin                          2.24.10-0ubuntu6.1                        programs for the GTK+ graphical user interface library
    ii  libgtk2.0-common                       2.24.10-0ubuntu6.1                        common files for the GTK+ graphical user interface library

screenshot

5

I've found two solutions:

  • disable GTK3 by exporting SWT_GTK3=0, then change the GTK2 theme to something else than oxygen (e.g QtCurve). Without the second step oxygen-gtk2 will crash eclipse too.
  • change GTK3 theme - I was unable to change it with the GUI tools provided with KDE. I had to install kde-gtk-config and remove settings.ini in ~/.config
  • the 'SWT_GTK3=0' trick didn't work for me, and nor did I (quickly enough) figure out how to install 'kde-gtk-config', however, using 'GTK+ Appearance' I was able to change the theme away from Oxygen (labeled 'Widget style' in the GUI), and that worked! thx – Matt S. Oct 21 '14 at 23:04
  • @MattS. how did the SWT_GTK3=0 "didn't work"? Was it still crashing or was the look the same? – Jakub Bochenski Oct 22 '14 at 10:26
  • @Bochenski, was still crashing. More precisely, eclipse would load, but on going into a specific dialog (preferences ---> Java Editor --> Syntax Coloring) eclipse would still hard crash. – Matt S. Oct 22 '14 at 18:32
  • @MattS. apparently there are bugs both in oxygen-gtk2 and -gtk3, see the updated anwser – Jakub Bochenski Oct 25 '14 at 16:02
  • SWT_GTK3=0 worked for me for ubuntu 14.04 and eclipse mars. Thanks!!! – Hemant Jul 6 '15 at 10:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.