2

Suddenly after shutting down Ubuntu and when reopenning, I get prompted to one shell of BusyBox. I only had a set of options in help there.

enter image description here

I tried to follow this solution: Boot drops to a (initramfs) prompts/busybox

I got a USB pen-drive and it has ISO of Ubuntu. I have selected "Try Ubuntu".

However, my Ubuntu is installed in an external hard disk (connected to the laptop via another USB port, other than the USB Pen drive), and I have Windows 8 installed by default in my laptop (in the internal hard disk). So when I am running the following command.

ubuntu@ubuntu:~$ sudo parted -l
Model: ATA ST1000LM024 HN-M (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  525MB   524MB   fat32        EFI system partition          boot
 2      525MB   567MB   41.9MB  fat32        Basic data partition          hidden
 3      567MB   701MB   134MB                Microsoft reserved partition  msftres
 4      701MB   2849MB  2147MB  ntfs         Basic data partition          hidden, diag
 5      2849MB  991GB   989GB   ntfs         Basic data partition          msftdata
 6      991GB   1000GB  8853MB  ntfs         Microsoft recovery partition  hidden, diag


Model: SanDisk Cruzer (scsi)
Disk /dev/sdb: 64.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      16.4kB  64.0GB  64.0GB  primary  fat32        boot, lba

None of this is actually my external hard disk in which my Ubuntu 14.04 is installed.

How can I solve this?

  • So your external disk is not even detected? – muru Oct 17 '14 at 9:00
  • Yeah. That's what I am feeling that it's not detected when I am running the "Try Ubuntu" but I can boot from the external hard disk. – soham Oct 17 '14 at 9:04
0

Just remove the ext2fsd 0.68 from windows. and fix the Ubuntu by any of the method you like on this page ( I go with fsck /dev/sdaX, where "X" is your partition where is Linux install)

and the problem will solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.