Currently, when I start my computer, this screen is shown. I do not have any other options, it boots into this within a second of starting my computer.

enter image description here

I used to have Windows 8.1 dual booted with Ubuntu. Today I decided that I don't need Ubuntu anymore and would rather have the extra space. These are the steps I took:

  • Opened disk manager. Deleted the partitions I believed to be Ubuntu (99% sure I allocated 100GB right next to my D: partition, and that's what I deleted and merged with D). There were 3 partitions next to D, which I believe somehow all belonged to Ubuntu, and when added together were 100GB. They were all marked as "Healthy primary partition"
  • Went into the UEFI settings and enabled Secure Boot, disabled CSM
  • Restarted and landed on the above screen.

If I do ls I get the following options:

(hd0) (hd0,gpt6) (hd0,gpt5) (hd0,gpt4) (hd0,gpt3) (hd0,gpt2) (hd0,gpt1)

When I do ls (hd0,gpt1) I get

Filesystem is fat

Everything else returns

Filesystem is unknown

I have previously made a recovery USB for my Windows, but I don't know how to boot from it. I don't particularly care about the stuff I had on my Windows machine and all I really want is to have a computer that boots into Windows. If I could have it as it was out of the box, that would be great. Any advice on how I should proceed?

Thank you

I accidentally made my computer boot to GNU GRUB, so I understand your issue.

I just enter exit until it boots to OS.

up vote 0 down vote accepted

Here's what worked for me. First of all, to quit GRUB2, if I ran exit twice, my computer would finally boot into Windows.

I then had to go to my UEFI settings:

  • Open charms bar (swipe from the right in)
  • Click Settings
  • Change PC settings (located at the bottom)
  • Update and Recovery
  • Recovery
  • Under Advanced Start Up, click Restart now

Once there, I was able to open the Boot menu from under the advanced options and I deleted the ubuntu entries.

Afterwards, I reinstalled Windows, though I don't think that's necessary. If you want to reinstall, that option is also under the PC Settings -> Update and Recovery -> Recovery.

If you ever want to go back into ubuntu, when you are choosing what operating system to run, select the more options button or whatever it says.next choose boot from another device, then select ubuntu. Then, it should bring up the ubuntu startup screen.press enter, then it will load ubuntu like normal.

  • 1
    This does not answer the question. – ubashu May 26 '17 at 2:58

4 years later, same problem, different solution.

I had deleted the Linux Partition through disk manager and then my computer would keep starting in the Grub terminal. To get rid of that, I had to do the following in an advanced command prompt:

Diskpart
List disk            (Note which disk is your System drive number. Mine was 2)
Sel disk 2
List vol               (Note which volume is the EFI partition mine is 4)
Sel vol 4
assign letter=V:       (or any other unassigned letter)
Exit

Then navigate into that directory:

V:
cd EFI
dir               (to see what is in there. I had neon and ubuntu in the list) 
rmdir /S ubuntu
rmdir /S neon 

And restart! Make note of whatever other directory in there that might be linux related and delete them. I initially didn't know neon was a Linux Flavour (I received my husband's old laptop, I didn't install these) and that caused further headaches as my computer kept restart in the grub terminal.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.