6

When I boot up in Ubuntu 14.10 beta 2, I get the following message for a moment on the screen:

error while reading descriptor: broken pipe:

The screen then goes black for a moment and then continues on to the login screen.

Can anyone advise me as to what this message indicates and what I need to do about it?

4

Seems like its a bug, so you might want to have a look at https://bugs.launchpad.net/ubuntu-gnome/+bug/1364630

  • 1
    The bug is mistitled. It includes not just Nvidia graphics, but also occurs in some circumstances (like mine) with Intel graphics. – Paul A. Jan 10 '15 at 0:13
1

I had the same issue. The following is my screen.

There are screens on:
    75854.lot       (08/24/2019 04:11:14 AM)        (Detached)

When I tried reattaching by using screen -r lot, it threw broken pipe: error. Therefore I tried,

screen -r 75854

and it worked!

0

Probably this could be due to varied reasons:

  1. some i/o issue.
  2. The write buffer of the pipe is full.
  3. Writing failed because there are no processes which could read from the pipe.

Also, it seems they had a bug earlier and re-installing the OS should fix the issue.

launchpad

  • Reinstalling is a last resort because it means that you have to recreate your entire operating environment. I've been hunting for a week for an answer that doesn't require me to do that. – Paul A. Jan 10 '15 at 0:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.