1

First of all, I'm new to Linux (using Ubuntu, and got 1 day of exp :p) so even though I think I know how to fix the problem, I don't know how to actually do it.

I wanted to change the keyboard layout, so I went into /usr/share/X11/xkb/symbols/ and changed the 'us' file.

first I remapped 'a' to 'q' as a test, and then deleted the pre-compiled (?) layouts in /var/lib/xkb/

To see the effect I should restart Xorg, but I have no idea how to do that, so I just restarted the computer.

The test worked perfectly, so I went on and tried to remap '-' to altgr. after that I rebooted again, but this time the /var/lib/xkb/ folder was empty and my keyboard did not work at all.

I imagine 'altgr' is an invalid keyword, and it throws an error when trying to compile the new layouts, and thats the reason the folder is empty.

How do I fix this? I saved the broken version of the 'us' file on the Desktop, and the original working compiled files as well, but I can't type my password in, in the Terminal without a keyboard, so I don't know how to move the working compiled files from the Desktop, or delete the broken 'us' script.

I imagine by deleting the broken 'us' script I could pick another layout language, and it would compile without an error.

As I write the last sentence I realize I might be able to disable the US layout and only use the Danish one. I'll try that and delete this post if it works (doubt it)

Hope someone can help me out. This is written on the live CD.

@dschinn1001: I use the newest ubuntu version, think it's 14.04 with unity. the problem is not finding a working layout. What I want is to use the dvorak layout, but change it, so '-' work as a modifier key, so I can press '- plus a' and get '$'.

I don't write here to get help with that, I'm sure I can figure that out myself with a bit of practice. What I want is a way to do this -> 'sudo mv old_dir new_dir' or whatever the real command is, but without a working keyboard. I can write the text using googles on-board keyboard, and copy/past but I can't press enter(in the Terminal), and i can't type my sudo password. I found a command I could C/P to into the Terminal that worked as 'enter' but it didn't work with my sudo password

  • Lukas Hansen

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.