4

I am using Juju 1.18.4. The environment is bootstrapped and here is the juju status environment: maas machines: "0": agent-state: started agent-version: 1.18.4 dns-name: poLap8.pvt.domain.net instance-id: /MAAS/api/1.0/nodes/node-9e78ad8c-5465-11e4-90b6-c80aa9bbfa5a/ series: trusty services: {}

I am tring to install juju-gui on machine:0 (aka poLap8.pvt.domain.net) using this command juju deploy --to 0 juju-gui --debug 2014-10-16 12:18:47 INFO juju.cmd supercommand.go:302 running juju-1.18.4-trusty -amd64 [gc] 2014-10-16 12:18:47 DEBUG juju api.go:171 trying cached API connection settings 2014-10-16 12:18:47 INFO juju api.go:242 connecting to API addresses: [poLap8.pv t.kaseya.net:17070] 2014-10-16 12:18:47 INFO juju apiclient.go:114 state/api: dialing "wss://poLap8. pvt.kaseya.net:17070/" 2014-10-16 12:18:47 INFO juju apiclient.go:124 state/api: connection established 2014-10-16 12:20:55 ERROR juju.cmd supercommand.go:305 cannot download charm "cs:trusty/juju-gui-10": Cannot access the charm store. Are you connected to the internet? Error details: Get https://store.juju.ubuntu.com/charm-info?charms=cs%3Atrusty%2Fjuju-gui-10: dial tcp 91.189.95.66:443: connection timed out

The Server[MasterShifu] were I am running juju command has dual NIC's - one Ethernet and one wlan. Ethernet interface is connected to private network[192.168.0.0] and run the DHCP, DNS and Proxy server for the network. Wlan interface is connect to a external routable network and has access to internet. I am able to access the juju store from this machine, here is the output curl store.juju.ubuntu.com/charm-info?charms=cs%3Atrusty%2Fjuju-gui-10 {"cs:trusty/juju-gui-10":{"canonical-url":"cs:trusty/juju-gui-10","revision":10,"sha256":"5b78eeea39c5425d8e9f95db85054fe34df932424a393af6c98a8577ef05f94f","digest":"francesco.banconi@canonical.com-20141003150150-yzikfrwp4wcbpn27"}}

Machine:0 aka poLap8.pvt.domain.net Has just Ethernet interface enable and in the 192.168.0.108 network - Has http_proxy and https_proxy configured to [MasterShifu] server. I am able to access the juju store url from this machine also and here is the output export | grep http declare -x http_proxy="192.168.0.1:3128" declare -x https_proxy="192.168.0.1:3128"

curl https://store.juju.ubuntu.com/charm-info?charms=cs%3Atrusty%2Fjuju-gui-10 {"cs:trusty/juju-gui-10":{"canonical-url":"cs:trusty/juju-gui-10","revision":10,"sha256":"5b78eeea39c5425d8e9f95db85054fe34df932424a393af6c98a8577ef05f94f","digest":"francesco.banconi@canonical.com-20141003150150-yzikfrwp4wcbpn27"}}ubuntu@poLap8:~$

I am still clueless on the cause of the issue. Provide me some hints on where to check further to fix this issue.

0

Had the same issue. tried .bashrc, /etc/environment, .juju/environments.yaml, .juju/environments/maas.jenv none worked.

juju set-env worked. and did set proxy in all machines.

This is how I tested. Instead of using curl on master machine.

  • juju run "curl https://store.juju.ubuntu.com/charm-info?charms=cs%3Ajuju-gui" --all and it failed in all nodes.
  • juju run "env | grep proxy" --all in all machines and saw none have proxy related environment variables set.
  • juju set-env http-proxy=http://PROXY_IP:8080/ and https-proxy
  • juju run "env | grep proxy" --all now returned proxy variables set in all machines

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.