0

Things I've tried

First off let me start by saying sudo ifconfig shows it up. and rfkill shows it unblocked. And im doing this all from a nonroot account. Also wifi DOES work on pure debian.

sudo rfkill unblock all

sudo ifconfig wlan0 up

sudo pico /usr/share/polkit-1/actions/org.freedesktop.NetworkManager.org

And change allow_avtive to yes

Then finally I tried

sudo -i
sudo ps -A | grep lightdm
startx

I could not figure out how to allow root log in in order to debug.. So the last command kills the x server and restarts it as root to achieve more or less that effect...

EDIT: sudo iwlist wlan0 scan shows my wifi card can see my access point :(

EDIT2 (Due to reply):

sudo iwconfig wlan0 modu 11g ->

Error for wireless request "Set Modulation" (8B2F) :
SET failed on device wlan0 ; Operation not supported.

iwconfig wlan0 channel 11 ->

Error for wireless request "Set Frequency" (8B04) :
SET failed on device wlan0 ; Operation not permitted.

About going into network manager I don't know what you mean by that? At the top right I have nothing in the top right but the close button to my browser window. So i went to the network settings by clicking the icon on my bottum bar but the option IGNORE IPV6 can only be applied to networks i create, I want wifi to scan on its own like it use to.

I will add I can connect to wifi over the terminal.

And the last step i just did it for kicks... I know thats VERY dumb to do but anyway its the only command that worked lol... by worked i mean no error returned.

NEW EDIT: I just tried reinstalling network-manager. Yet after installing the plasma-nm widget it still has the wifi checkbox greyed out, and doesnt scan networks.

NEW EDIT (based on comment):

lspci -nn | grep 0280 ->

04:00.0 Network controller [0280]: Qualcomm Atheros AR93xx Wireless Network Adapter [168c:0030] (rev 01)

iwconfig ->

eth0      no wireless extensions.
lo        no wireless extensions.
wlan0     IEEE 802.11abgn  Mode:Master  Tx-Power=16 dBm   
      Retry  long limit:7   RTS thr:off   Fragment thr:off
      Power Management:off
  • Please show the results of: lspci -nn | grep 0280 and also: iwconfig. Thanks. – chili555 Oct 15 '14 at 23:06
1

Try to change the parameter of wireless driver as follows and check the reported issuse.

change 802.11bgn to 802.11bg.

iwconfig wlan0 modu 11g

change the wep encryption to just wpa2 (CCMP)(AES) not (TKIP) if you have that option it will work best.

wpa-pairwise CCMP

Set your wireless channel in the router to 1 or 11 then save the router configuration and reboot it.

iwconfig wlan0 channel #

Go into network manager at top right corner of the screen and click on edit connections>wireless tab and set IPV6 to ignore.

Now open the terminal CTRL+ALT+_T then copy and paste the following code one line at a time for accuracy:

echo "options rtl8192ce swenc=1 ips=0" | sudo tee /etc/modprobe.d/rtl8192ce.conf
sudo modprobe -rfv rtl8192ce
sudo modprobe -v rtl8192ce

IF the issue persists, try compiling new driver. Hope this helps!

  • Why do you believe his wireless driver is rtl8192ce? – chili555 Oct 15 '14 at 21:05
  • @chili555 It's an example code as per our test environment. – vembutech Oct 15 '14 at 21:07
  • However, if he hasn't that specific driver, those steps do nothing but waste time. – chili555 Oct 15 '14 at 21:25
  • @chili555 yes got it. Will rectify it from next post.Thank you. – vembutech Oct 15 '14 at 22:18
  • =( still need help.. what do you mean go into network manager at top right. I went instead to the bottom right and clicked on network settigns but the only way i can set IPV6 to ignore is by creating a network.. i want the wifi to be able to scan networks on its own. Why did this randomly break? Do you have any clue? It use to all work.. first I had to make a script to unblock via rfkill, then another to do ifconfid wlan0 up, then i had to modify policies.. its like the mroe time passes the more things i have to do to get it to work lol – Banned_User Oct 17 '14 at 22:09
0

Ok so i hate to do this... but it solved my problem so im doign it.

sudo apt-get install wicd

sudo service network-manager stop

sudo service wicd start

Problem solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.