1

This question already has an answer here:

My laptop is connected to two external monitors. When I switch workspaces, only the main monitor will switch, and the second monitor will stay fixed.

Since I want to switch between several task, each requiring the use of two monitors, this is really annoying.

I found another similar question here for Ubuntu 11.10. The answer provided was to execute the command:

gconftool-2 --set /desktop/gnome/shell/windows/workspaces_only_on_primary false --type bool

and re-login.

I managed to execute the command (no errors), but the problem continued even after a re-login.

Is this solvable on Ubuntu 14.04?

marked as duplicate by edwinksl, TheWanderer, Eric Carvalho, Anwar, Aaron Oct 3 '16 at 14:00

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

This worked for me:

gsettings set org.gnome.shell.overrides workspaces-only-on-primary false
0

This works for me. Open up dconf editor, org > gnome > shell > overrides, uncheck workspaces-only-on-primary

Not the answer you're looking for? Browse other questions tagged or ask your own question.