6

First of all, apologies but I am very new to using kubuntu, so I would need a very basic step by step answer to solve this problem. Since my last update I am getting this error message:

KDE power management system could not be initialized.

When I go into 'power management' it says:

Power management configuration module could not be loaded. The power management service appears not to be running. This can be solved by starting or scheduling it inside 'startup and shutdown'

I followed the steps that I found mentioned by others online.

Go into System Settings --> Startup and Shutdown --> Service Manager (tab) --> Startup Service and tick the 'Power Management' box.

However, this was already ticked and also I have a desktop computer so don't know if this is actually needed. I tried unchecking it to see if it makes a difference but it does not.

I am very confused as to what should be done to solve this as now I don't have the option to shutdown the computer or put it into sleep mode. Any advice would be very much appreciated. Thank you.

  • 1
    Where/when does this error appear? – terdon Oct 15 '14 at 11:41
  • Once I log in it pops up as a notification. – nashp86 Oct 18 '14 at 17:53
  • 1
    I got this only after upgrading to 14.10. What release are you using? – int_ua Oct 29 '14 at 22:05
3

I had the same issue (and WiFi was not working). Reinstalling of upower solved it:

sudo apt-get purge upower
sudo apt-get install upower
| improve this answer | |
1

In the application launcher menu the entries for Sleep, Shut Down and Restart were missing! Also the WIFI didn't work.

I reinstalled (or just reinitialized) upower:

sudo apt-get install upower
| improve this answer | |
0

I had the same problem and finally figured it out.

The issue is the permissions on /usr/lib/dbus-1.0/dbus-daemon-launch-helper

If you do an ls -l it should look like this (except, maybe the file size/date):

-rwsr-xr-- 1 root messagebus 310800 Sep 17 10:24 dbus-daemon-launch-helper

Mine actually looked ok. but you should check.

What had messed me up was that the messagebus user was assigned to group nvram in /etc/passwd!

So /etc/group looked like this:

....
nvram:x:106:
....
messsagebus:x:115:
....

And /etc/ passwd had this line for messagebus:

messagebus:x:102:106::/var/run/dbus:/bin/false

Not sure how that happened. So I changed the 106 in passwd to be 115, rebooted, and that did it. Also, you may have noticed that other global services like udev don't work either. That prevents you from automounting USB sticks and it prevented my monitors from getting put in the right order on boot. This will fix all of that.

Hope that helps!

| improve this answer | |
  • Nope, permissions and group is fine and I'm still getting this error. – int_ua Oct 29 '14 at 22:15
  • Can you determine if you can run dbus-daemon-launch-helper (probably as root). Perhaps it is corrupt? – user58418 Oct 31 '14 at 12:19
  • Well, it turned out to be the most simple one: I accidentally (well, almost) deleted upower daemon. – int_ua Nov 1 '14 at 22:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.