2

Ubuntu Shortcut keys are clashing with IntelliJ IDEA shortcut keys.

Example Ctrl+Alt+L This formats the code in IntelliJ IDEA While this locks the ubuntu desktop. Also Windows+L also locks the desktop.

I want to only use Windows+L key to lock desktop, so that Ctrl+Alt+L can be used in IntelliJ IDEA.

Please assist.

1

IntelliJ case

Go to: File | Settings | Keymap and change to Alt+L for instance:

enter image description here

Or Ubuntu case:

Go to System Settings | Keyboard and change Lock screen option:

enter image description here

  • How about shortcuts that are not listed under System Settings -> Keyboard -> Shortcuts? (like Ctrl+Alt+F7) – Superole Aug 31 '17 at 10:28
0

This can happen if you use Ctrl + Alt in OS as layout change keys combination, for example.

Try using Left Ctrl + Left Alt to separate OS and Intellij key listeners. In this case more general Intellij's Ctrl + Alt + Slash keys combination will work for the right side keys combination in IDE: Right Ctrl + Right Alt.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.