I'm not the only one with this probmem.

Switching to workman layout.

I tried on ubuntu 12 and 14 on two different computers with the same error.

Following instructions in this question but get error message Error loading new keyboard description. Can't figure it out. I copy and paste from tutorials so it is not my spelling. (I am running in virtualbox on windows). I do this. First download workman.iso15.kmap.

sudo cp workman.iso15.kmap /usr/share/X11/xkb/symbols/workman

setxkbmap -v workman && xset r 66 

This is my error message.

edler@Prog88:~$ setxkbmap -v workman -v
Warning! Multiple definitions of keyboard layout
         Using command line, ignoring X server
Applied rules from evdev:
rules:      evdev
model:      pc105
layout:     workman
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwerty)
types:      complete
compat:     complete
symbols:    pc+workman+inet(evdev)
geometry:   pc(pc105)
Error loading new keyboard description

Also. This worked one year ago in the 12.04 linux. There is definately the right keyboard description. But now it does not load (it did one year ago). Strange.

up vote 1 down vote accepted

Works in 14.04 LTS

  1. Click on the Settings Icon in the top-right-most of the panel (on the right of Time)
  2. Click on System Settings
  3. Under Hardware section, Select Keybord
  4. Under Typing tab, Click Text Entry
  5. Click + button to add a keyboard layout
    Type in Workman, you'll find this, asking you to select out of available:

    keyboard layout for workman

  6. Select, English (Workman). Then, click Add

  7. Now, to switch between languages(keyboard layout), Press, Super+Space
    Or you can change it by clicking Keyboard Layout icon in the panel on the left of battery indicator.
  • Ideally I would like it to work without having to use 14. But it will do. BTW. Great thanks ! A lot. – r4. Oct 21 '14 at 16:08
  • Does not work in linux 32 bit. Posted new question about that. – r4. Oct 26 '14 at 13:49

As of Ubuntu 17.04 release, switching to workman layout using command line, it only takes

setxkbmap -v us workman

And, to rollback to qwerty again, do this

setxkbmap -v us

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.