3

I tried searching but I couldn't find this one specifically.

When using the latest Chromium (version 37.0.2062.120 Ubuntu 14.04 (281580)) HTML5 video with audio will be out of sync. Usually, the audio plays further ahead than the video. I've tested it with YouTube HTML5 video and with loading an HTML5 video with audio directly into the browser.

It's a very noticeable difference, usually a whole second or more of latency.

I thought the problem might have been due to my audio backend, but I'd prefer not to remove Pulseaudio if at all possible.

1
  • I'm not sure if this helps or not, but I'm a web developer who's working on an HTML5 video heavy website. I use a Mac, and I have the same issue in Chrome. So I doubt that this bug is unique to the Linux build or your audio back-end. Nov 22 '14 at 7:56
2

Actually, I found this answer myself snooping around at a later date, shortly before I switched to Arch Linux.

In pavucontrol, you can head to your output device in question and select the "advanced" dropdown. There's an option labeled "Latency Offset".

screen shot

For some reason, mine was set to 1000.00. Simply set it to 0.00 and the problem goes away.

2
  • On my Raspberry Pi 3 with Chromium the Latency Offset worked beautifully! first: sudo apt-get install pavucontrol -- then run: pavucontrol - I first used a video with someone speaking to get the audio visually close, then I used this video youtube.com/watch?v=M8ERqeu7pP0 to sync more accurately with the beats and ended up with about an 800ms offset setting.
    – JxAxMxIxN
    Oct 5 '16 at 5:04
  • pavucontrol only allows up to 99ms offset, and I have a lot more than that
    – JayEye
    May 17 '19 at 19:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.