7

I'm having some trouble getting Eclipse Luna to work. I downloaded the tar.gz from their site and I downloaded the tar.gz for the Java JDK. I extracted everything and Eclipse opens properly, but when I try to make a new project, it crashes on me. In the terminal I ran java -version and it tells me I have version 1.8.0_25 so I don't think I have an issue with java. Now, this happens if I try to make any kind of project. Eclipse opens the wizard for creating a new project of a particular type and then the whole application crashes. I'm using Kubuntu 14.04. Any ideas?

  • 1
    Is there a stacktrace from the crash? Can you show us the output of get when you start eclipse from the terminal? – MadMike Oct 15 '14 at 6:47
  • there is a generated file when eclipse is crashed in the same directory of eclipse go to figure out what is tells you. Or past it's contents. – Manee Osman Oct 15 '14 at 7:48
  • When I run it in the terminal, Eclipse does give me a ClassCastException, but it still opens. When I try to create a new project, I get this: java: /build/buildd/gtk2-engines-oxygen-1.4.5/src/animations/oxygencomboboxdata.cpp:87: void Oxygen::ComboBoxData::setButton(GtkWidget*): Assertion '!_button._widget' failed. . – beznez Oct 15 '14 at 13:25
  • On KDE oxygen is the default theme, but I do not have oxygen applied right now. – beznez Oct 15 '14 at 13:27
  • Just found related content, worked fine for me, except look and feel is not what I like now.. Hope that helped. askubuntu.com/questions/396410/… – marcoooo Oct 25 '14 at 14:15
9

As indicated in Eclipse auto shutdowns when creating new project one workaround to this bug is to change the GTK2 theme in System Preferences -> Application Appearance -> GTK (I personally use Aurora: sudo apt-get install -y gtk2-engines-aurora).

Alternatively, a patch to oxygen is available here, and has been pushed to the active development branch of oxygen. oxygen-gtk2-1.4.6-1 should be OK but as of now oxygen-gtk2-1.4.5 is still the most recent stable version.

  • 3
    or run eclipse as GTK2_RC_FILES=/usr/share/themes/Raleigh/gtk-2.0/gtkrc eclipse – Ohad Cohen Jan 17 '15 at 0:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.