I'm trying to execute a .sh file, but its opening in gedit. I permitted it to be "executed as program", but it's still not working. I'm on a machine running Ubuntu 14.04LTS.

  • Can you find "Run in terminal" in the right click menu, under "Open with..." or so? Oct 14, 2014 at 22:36
  • Nope. Terminal isnt in the list. Oct 14, 2014 at 22:39
  • Maybe I should try Linux Mint, Ubuntu is too slow when launching programs Oct 14, 2014 at 22:42
  • Maybe, but that's a different question (Lubuntu and Xubuntu are other 'fast' options); Do you know what is slow? If it's really starting programs - do you have limited RAM? (Anyway, just some ideas, but that does not belong to this question) Oct 14, 2014 at 22:49
  • I think 3GB are enough... Oct 14, 2014 at 22:49

1 Answer 1


Setting the "executed as program" permission is not enough as there's a global Nautilus preference that alter the behavior when you click on an executable text file.

Open the Nautilus Preferences (Edit -> Preferences) and select the Behavior tab:

enter image description here

Select the "Ask each time" option to get the following popup when you click on your .sh files:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.