I have a question just occurred to me today. I was using Ubuntu on virtualbox and it was normal. But today it just cannot get online. I tried and the host Win8 can ping the Ubuntu, and Ubuntu can ping host and the wireless router as well. Also Ubuntu can ping I used Bridged Adapter. But I cannot get on line with a web browser, neither the dropbox cannot be connected.

Any good ideas?Thank you!

  • Seems like a DNS issue. have you tried pinging google.com or any other web address by name?
    – heemayl
    Oct 14, 2014 at 22:12
  • Yes, I tried. And it does not work.
    – Cosmozhang
    Oct 14, 2014 at 22:32
  • So definitely a DNS problem. Does host google.com successfully resolve? How did you configure the network connection of the guest system (DHCP, manual)? Oct 15, 2014 at 1:26

1 Answer 1


Just solved it. Simple and easy. Delete /etc/resolv.conf

  • Yes, it turned out to be a DNS issue. I think you meant /etc/resolv.conf. remember this file will be auto generated by resolvconf program.
    – heemayl
    Oct 14, 2014 at 22:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.