0

With Ubuntu 14.04 and my new System76 laptop. I shut down after being connected to a monitor at home. Came into work and connected to a monitor.

The monitor was not detected in

All Settings -> Displayed

I tried several other monitors and HDMI cables. All had the same problem. I tried rebooting the laptop and rebooting the monitor, all to no avail. When I looked at xrandr to dive a level deeper, it did not list an HDMI adapter

doug@76:~$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected (normal left inverted right x axis y axis)
   1920x1080      60.1 +   59.9  
   1680x1050      60.0     59.9  
   1600x1024      60.2  
   1400x1050      60.0  
   1280x1024      60.0  
   1440x900       59.9  
   1280x960       60.0  
   1360x768       59.8     60.0  
   1152x864       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Finally I got fed up and explicitly shut down. Once I did this, the HDMI began to be detected.

I was trying to figure out if there was a simple human error involved or how I might go about troubleshooting this problem further?

0

I, too, have a System76 laptop, and I think this can be solved by installing the System76 driver (which, for some reason, doesn't come preinstalled).

You can get the driver here.

  • I do have the system76 driver. Mine came with a system76 ppa in sources.list.d. – Doug T. Oct 14 '14 at 19:21
  • Maybe a reinstall of the driver will fix it – zwork Oct 14 '14 at 19:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.