1

Turn on the PC, get normally to the login screen. But when I login, the desktop doesn't seem to load. I've waited half an hour but it still didn't load.

I can get to the root by using the GRUB screen at the startup by pressing shift, but I can't use the "apt-get update" command because of a problem on my ppa repository.

This problem happened to me a lot already, but I don't remember how to fix it. It was always related to my NVIDIA card, but I have no idea if it's that driver's fault this time.

@edit Now I'm able to do apt-get update, but it gives some errors like "failed to fetch".

I tried to do apt-get install --reinstall ubuntu-desktop, but it returns "unable to fetch some archives, maybe run apt-get update or try with --fix-missing?" This actually appears whenever I try to download something.

Somebody please help me, I'm even thinking about going back to windows... maybe it's not really worth to have limited software on linux if I'm getting so many errors...

Probably I'm the one to blame.

6
  • Are you connected to the internet? Is that the reason why apt-get is failing? Please post the full output of apt-get update.
    – Gremlin
    Oct 14, 2014 at 17:05
  • We need more info. Please share your entries in the /etc/apt/sources.list. Have you installed something recently? Also post the output of lshw -c display.
    – heemayl
    Oct 14, 2014 at 17:07
  • I installed a lot of stuff lately, I followed this: code.google.com/p/pysnip/wiki/SetupUbuntu
    – user285672
    Oct 14, 2014 at 17:44
  • How can I get to see the entries on sources.list? I mean, I can't even login... and yes, I'm connected to the internet. How can I get the full output of apt-get update?
    – user285672
    Oct 14, 2014 at 17:46
  • UPDATE: I got apt-get update and apt-get install to work! What should I do now to get to desktop again?
    – user285672
    Oct 14, 2014 at 17:53

1 Answer 1

1

Just press Ctrl+Alt+T to go to a terminal and type:

sudo su
apt-get update
apt-get install --reinstall ubuntu-desktop
apt-get install --reinstall unity
apt-get remove --purge nvidia*
apt-get install nvidia-current
reboot

As that solved for me...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.