I realize that there are a lot of information on here/Google about this, but I think my problem is different.


I upgraded 9.10 -> 10.04 -> 10.10 -> 11.04. 11.04 failed and I was stuck at the grub prompt. As you can see in the photo, I'm having a hard time loading anything from the disk.

I have three disks, /dev/sdc being the OS disk on which I have Ubuntu Server. This is a pure Ubuntu box.

Please help :'(

  • Have you tried the well known livecd+chroot method to restore grub? – enzotib Jul 19 '11 at 10:21
  • I haven't seen a complete guide for this yet. Firstly, what live CD would I need? 11.04? Someone suggested that the alternate live CD is required, but I can't find it anywhere on ubuntu.com anymore. Is it as easy as mount /dev/sdc1 /mnt; chroot /mnt; grub-update;? – Znarkus Jul 19 '11 at 13:17
  • Not exactly so easy: see here: help.ubuntu.com/community/Grub2#ChRoot – enzotib Jul 19 '11 at 13:26

I booted the Ubuntu Server 11.04 CD and chose Rescure console. Clicked Esc until the main menu came up. Then selected Execute a shell.

rescure mode

I followed the instructions over at https://help.ubuntu.com/community/Grub2#ChRoot like @enzotib suggested. These are the commands I used, which are modified for the BusyBox shell.

mount /dev/sdc1 /mnt
for i in /dev /dev/pts /proc /sys; do mount $i /mnt$i -o bind; done
chroot /mnt
/usr/sbin/grub-install /dev/sdc

After the reboot I was presented with

error: no suitable mode found

Yay. After a couple of reboots and some searching I came to understand I just had to wait, then Ubuntu would boot. After it did, I logged in and ran update-grub and then rebooted. Problem solved! Thank you @enzotib.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.