1

my wireless isn't working since 14.04 on my Lenovo Ideapad N581. I can see the Network, but cannot connect to it.

I can only connect to the network, when I switch the mode from 802.11bgn to 802.11abg. So I conclude that the n protocol is the problem.

But since I cannot change the mode of any other network then my own, this remains a big problem.

I run the script as told in My wireless/WiFi connection does not work. What information is needed to diagnose the issue?.

You can find the result here: script result.

I also tried to install the linux-firmware and linux-firmware-nonfree. But everything's still the same.

So can anyone pls help me? I really need a working wireless :)

  • Have you tried to install the proprietary Broadcom driver? (bcmwl) – P.-H. Lin Oct 14 '14 at 14:18
  • I tried, but wasn't helping. Wild Man solved my problem. Thanks anyway! – King_SaGo Oct 15 '14 at 13:16
2

Do:

sudo apt-get purge bcmwl-kernel-source

Then reboot and let ubuntu load the brcmsmac driver if it does not load then you will need to remove brcmsmac and bcma driver's from the blacklist file like so:

sudo sed 's/blacklist brcmsmac//' -i /etc/modprobe.d/blacklist.conf
sudo sed 's/blacklist bcma//' -i /etc/modprobe.d/blacklist.conf

Then blacklist the b43 and ssb driver:

sudo -i
echo "blacklist b43" >>  /etc/modprobe.d/blacklist.conf
echo "blacklist ssb" >>  /etc/modprobe.d/blacklist.conf

exit Reboot

  • Thanks! It worked :) At least with my home network. Will try it soon with other networks (university, work). – King_SaGo Oct 15 '14 at 13:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.