0

I am trying to install "Upsize.C" and "noise-generator-0.2.5" for gimp.

for upsize.c happens this:

christian@mobile02:~/software/gimp-plug-ins$ gimptool-2.0 --install upsize.c
gcc  -pthread -I/usr/include/gtk-2.0 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/cairo -I/usr/include/libpng12 -I/usr/include/glib-2.0 -I/usr/lib/i386-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/lib/i386-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/harfbuzz -I/usr/include/gimp-2.0   -o /home/christian/.gimp-2.8/plug-ins/upsize upsize.c  -lgimpui-2.0 -lgimpwidgets-2.0 -lgimpmodule-2.0 -lgimp-2.0 -lgimpmath-2.0 -lgimpconfig-2.0 -lgimpcolor-2.0 -lgimpbase-2.0 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfontconfig -lgobject-2.0 -lglib-2.0 -lfreetype   
/usr/bin/ld: /tmp/ccCGidxO.o: undefined reference to symbol 'floor@@GLIBC_2.0'
//lib/i386-linux-gnu/libm.so.6: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status

trying to install noise generator happens this:

christian@mobile02:~/software/gimp-plug-ins/noise-generator-0.2.5$ make
make -C po
make[1]: Entering directory `/home/christian/software/gimp-plug-ins/noise-generator-0.2.5/po'
msgfmt -c -v -o de.mo de.po
de.po:7: warning: header field 'Language' missing in header
34 translated messages.
msgfmt -c -v -o pl.mo pl.po
pl.po:2: warning: header field 'Language' missing in header
34 translated messages.
make[1]: Leaving directory `/home/christian/software/gimp-plug-ins/noise-generator-0.2.5/po'
make -C src
make[1]: Entering directory `/home/christian/software/gimp-plug-ins/noise-generator-0.2.5/src'
cc -O3 -Wall -pthread -I/usr/include/gtk-2.0 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/cairo -I/usr/include/libpng12 -I/usr/include/glib-2.0 -I/usr/lib/i386-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/lib/i386-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/harfbuzz -I/usr/include/gimp-2.0   -o noise-generator plugin.o noise.o events.o interface.o colour.o poisson_gui.o gauss_gui.o uniform_gui.o laplace_gui.o lorentz_gui.o -lgimpui-2.0 -lgimpwidgets-2.0 -lgimpmodule-2.0 -lgimp-2.0 -lgimpmath-2.0 -lgimpconfig-2.0 -lgimpcolor-2.0 -lgimpbase-2.0 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfontconfig -lgobject-2.0 -lglib-2.0 -lfreetype  
/usr/bin/ld: noise.o: undefined reference to symbol 'sqrtf@@GLIBC_2.0'
//lib/i386-linux-gnu/libm.so.6: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
make[1]: *** [noise-generator] Error 1
make[1]: Leaving directory `/home/christian/software/gimp-plug-ins/noise-generator-0.2.5/src'
make: *** [src] Error 2

make install returns:

christian@mobile02:~/software/gimp-plug-ins/noise-generator-0.2.5$ make install
make -C po install
make[1]: Entering directory `/home/christian/software/gimp-plug-ins/noise-generator-0.2.5/po'
msgfmt -c -v -o de.mo de.po
de.po:7: warning: header field 'Language' missing in header
34 translated messages.
msgfmt -c -v -o pl.mo pl.po
pl.po:2: warning: header field 'Language' missing in header
34 translated messages.
for L in de pl; \
    do install -v -m 0644 $L.mo "/usr/share/locale/$L/LC_MESSAGES/gimp20-noise-generator-plug-in.mo"; \
done
install: cannot remove ‘/usr/share/locale/de/LC_MESSAGES/gimp20-noise-generator-plug-in.mo’: Permission denied
install: cannot remove ‘/usr/share/locale/pl/LC_MESSAGES/gimp20-noise-generator-plug-in.mo’: Permission denied
make[1]: *** [install] Error 1
make[1]: Leaving directory `/home/christian/software/gimp-plug-ins/noise-generator-0.2.5/po'
make: *** [install] Error 2

now I do not understand what is wrong, I did this operation already several times successfully on previous versions

still I am sure it is something very simple

Thank you all for your help

1

I know this answer is a lot late but if you are facing the same issue, if found a solution for noise generator(I didn't use the other plugin yet). In the make file for src directory in noise generator folder add -lm to $(PLUGIN)

CFLAGS = -O3 -Wall $(shell gimptool-2.0 --cflags)
LIBS = $(shell gimptool-2.0 --libs)
PLUGIN = noise-generator
SOURCES = plugin.c noise.c events.c interface.c colour.c poisson_gui.c gauss_gui.c uniform_gui.c laplace_gui.c lorentz_gui.c
HEADERS = plugin.h interface.h messages.h
# END CONFIG ##################################################################

.PHONY: all install userinstall clean uninstall useruninstall

all: $(PLUGIN)

OBJECTS = $(subst .c,.o,$(SOURCES))

$(PLUGIN): $(OBJECTS)
    $(CC) $(CFLAGS) -o $@ $^ $(LIBS) -lm

%.o: %.c $(HEADERS)
    $(CC) $(CFLAGS) -c -o $@ $*.c -lm

install: $(PLUGIN)
    @gimptool-2.0 --install-admin-bin $^

userinstall: $(PLUGIN)
    @gimptool-2.0 --install-bin $^

uninstall:
    @gimptool-2.0 --uninstall-admin-bin $(PLUGIN)

useruninstall:
    @gimptool-2.0 --uninstall-bin $(PLUGIN)

clean:
    rm -f *.o *~ $(PLUGIN)

also for make install you need to run as root. So do sudo su before giving the make install command.

I am not sure if it works for Xubuntu 14.04 but it certainly works on Ubuntu 15.04

Hope it helps

  • also I am late: – Christian Hartmann Oct 13 '16 at 13:38
  • also I am late: – Christian Hartmann Oct 13 '16 at 13:39
  • Also I am late: I tried your suggestion initially with no success. That I tried sudo make clean sudo make clean install and it worked, on Xubuntu 14 as well as on Ubuntu 16 (where I had the same problem). “Upsize.c” is still an enigma, but it is extremely useful Since I usse versions newer than 12.04 I have this problem. – Christian Hartmann Oct 13 '16 at 13:45
1

try this

sudo apt-get install libgimp2.0-dev
sudo make install

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.