Looking for some help as I have already posted in numerous help forums and was still unable to resolve an issue.

System Info: HP Probook 6470b (Ubuntu 14.04 LTS and Win7) Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04) Kernel: 3.13.0-37-generic

The Problem: Both audio channels are being played over only the left speaker when booted into Ubuntu while leaving the right speaker silent. Using the test sound ques in the sound settings plays both the 'front left' and 'front right' ques in the left speaker.

What I know/tried: Both speakers are physically capable of functioning as sound is correct when booted into Win7. Headphone audio is correct and functioning with both channels playing on their respective sides. The alsamixer settings are correct and nothing is out of balance or unintentionally muted. The pavucontrol settings are correct and nothing is out of balance or muted. I have also tried all the configuration profiles with no positive change. (Currently set in 'Analogue Stereo Duplex'.)

I would appreciate any kind of help as I am very stumped. I can provide more information as needed relevant to the fix. Thank you, Kent

  • May be a change in file /etc/modprobe.d/alsa-base.conf could be ok : Run "Alsa-info" to show your audio config copying the following command in a terminal , choose "upload" option when asked ("tab" key to select it) an post url printed at the end. wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
    – laugeo
    Oct 14, 2014 at 15:02
  • Ok. Thank you very much as you are the first person that has been able to get me started at least. Here is the URL: alsa-project.org/db/?f=6954074e409f58f077cc492d3ae7fda461226bee Oct 14, 2014 at 22:10

1 Answer 1


From alsa-info your sound card codec is IDT 92HD81B1X5 .

The codec model can also be found running this command:

lspci -v | grep -A7 -i "audio"

From this page HDA audio models.txt, the closest known codec is STAC92HD83 (IDT/sigmatel).

From this list, you see which option you can try (more or less randomly) in the /etc/modprobe.d/alsa-base.conf file until your speakers are ok:

ref Reference board
hp-dv7-4000 HP dv-7 4000
hp_cNB11_intquad HP CNB models with 4 speakers
hp-zephyr HP Zephyr
hp-led HP with broken BIOS for mute LED
hp-inv-led HP with broken BIOS for inverted mute LED hp-mic-led HP with mic-mute LED
headset-jack Dell Latitude with a 4-pin headset jack
hp-envy-bass Pin fixup for HP Envy bass speaker (NID 0x0f)
hp-envy-ts-bass Pin fixup for HP Envy TS bass speaker (NID 0x10)
hp-bnb13-eq Hardware equalizer setup for HP laptops
auto BIOS setup (default)

To apply your first choice (f.i. the first in the list: "ref"), edit the alsabase.conf running this command:

sudo gedit /etc/modprobe.d/alsa-base.conf

Add this line at the end:
options snd-hda-intel model=ref
save , reboot and test speaker.
If not ok, try the next model (f.i. hp-dv7-4000) modifying again last line in alsa-base.conf to :
options snd-hda-intel model=hp-dv7-4000
Again, save , reboot and test speaker.
If you are lucky you will have 2 speakers ...

  • If it stills not good after trying many models, install alsa-tools to run hdajackretask, which is a low level wiring program for HDA sound card:
    you can change codec output to physical jack connections : f.i. click "override" near "internal speaker" , then you can choose another output in the list (like line out ) to replace the present "speaker" which is not good. You will have to close every sound program, including alsamixer, and to unmute master fader (with alsamixer) when you have applied a change.
    Some info here
  • Hello. And thank you for staying with me as I have been unable to try. Oct 19, 2014 at 0:52
  • Hello. And thank you for staying with me as I have been unable to try. So I started out by trying hdajackretask. I tried all the options and whatnot, with no positive change. I however don't quite understand what to edit in the configuration file as there seems to be a few fitting things. Here is an image of the conf. file: imgur.com/VS2Igv1 Oct 19, 2014 at 0:59
  • Add one line f.i. options snd-hda-intel model=ref at the alsa-base.conf file's end , after all others lines that are not modified.
    – laugeo
    Oct 19, 2014 at 8:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.