1

I'm using ubuntu 14.04. After booting, the login screen freezes and I can't use keyboard and mouse, actually no input hardware at all.

In recovery mode, it works fine.
I tried to sudo apt-get update in recovery mode and re-boot, but nothing happens.

2

I noticed that USB mouse/keyword worked in the recovery mode every time. The problem is that I end up with crappy graphics mode in recovery so I basically just force the normal boot to go through recovery by adding "recovery" to the GRUB_CMDLINE_LINUX in /etc/default/grub. My line looks like the following:

GRUB_CMDLINE_LINUX="recovery acpi=force irqpoll usbcore.autosuspend=-1"

along with all the options that I have tried and failed. I also tried the following (from another askubuntu question), which worked for some time:

 sudo powernap-action --disable usb_autosuspend

However, I think "recovery" is the only thing you need. You had to press enter a couple of times to continue booting if you go this route, but at least USB works on boot and you have good screen resolution.

PS. I had this problem with Ubuntu 14.04, and after switching to Mint 17, had the same issue. I tried various options, some worked for a while and then stopped working, but I eventually ended up with this really frustrating problem reboot after reboot. I don't believe this is a hardware issue, or I don't believe this is a hardware issue that Ubuntu cannot work around. My dual-boot Win7 had no such problems whatsoever. I was pulling my hair out and seriously thought about abandoning Ubuntu based distros.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.