0

I have Ubuntu 14.04 LTS installed on an HP Touchsmart laptop and I'm having issues connecting to the Internet at home.

My PC has a Realtek RTL8188EE 802.11bgn Wi-Fi Adapter, and it dual-boots Windows 8.1 and Ubuntu 14.04 LTS. When I'm using Ubuntu and I'm connected to my home network, I can't access the Internet. Even the gateway address is unresponsive to pings.

The funny thing is, my computer connects to the Internet just fine when I'm on Windows or I'm connected to my school's wi-fi or that of one of my friends.

My router is an Arris TG852 (I think that's the right model number) router/modem combo, but I also have a Linksys wrt100 tethered to it as a repeater in order to service mobile devices on the network (for some reason they can't connect to the Arris router).

Is there a way to fix this issue with software or by fiddling with network settings in Ubuntu and on the router, or is the only solution to completely replace the Arris/Linksys improvised setup with a quality router?

Here is the output of the ifconfig command:

eth0      Link encap:Ethernet  HWaddr c4:34:6b:43:f4:3f  
        UP BROADCAST MULTICAST  MTU:1500  Metric:1
        RX packets:50075 errors:0 dropped:0 overruns:0 frame:0
        TX packets:4412 errors:0 dropped:0 overruns:0 carrier:0
        collisions:0 txqueuelen:1000 
        RX bytes:8949360 (8.9 MB)  TX bytes:661356 (661.3 KB)

lo        Link encap:Local Loopback  
        inet addr:127.0.0.1  Mask:255.0.0.0
        inet6 addr: ::1/128 Scope:Host
        UP LOOPBACK RUNNING  MTU:65536  Metric:1
        RX packets:7198 errors:0 dropped:0 overruns:0 frame:0
        TX packets:7198 errors:0 dropped:0 overruns:0 carrier:0
        collisions:0 txqueuelen:0 
        RX bytes:1566049 (1.5 MB)  TX bytes:1566049 (1.5 MB)

wlan0     Link encap:Ethernet  HWaddr 9c:d2:1e:7a:15:da  
  inet addr:192.168.1.114  Bcast:192.168.1.255          Mask:255.255.255.0
        inet6 addr: fe80::9ed2:1eff:fe7a:15da/64 Scope:Link
        UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
        RX packets:29605 errors:0 dropped:0 overruns:0 frame:0
        TX packets:23378 errors:0 dropped:0 overruns:0 carrier:0
        collisions:0 txqueuelen:1000 
        RX bytes:21292553 (21.2 MB)  TX bytes:3560977 (3.5 MB)

** Update ** I installed the Realtek 8188CE driver, which resolved some connectivity issues. I also unplugged the secondary router from the primary one, eliminating any possible issues between the two of them and my laptop. My laptop worked perfectly fine for a couple hours, but then suddenly lost connectivity. I tried restarting my wireless adapter several times, and even restarting my laptop, but I still can't ping Google. I can't even ping the router itself. Help!

  • So your wireless adapter works when you connected to your school's / your friends' WiFi hotspot on Ubuntu? – P.-H. Lin Oct 14 '14 at 10:00
  • Please post the output of ifconfig command. – kashminder Oct 14 '14 at 11:36
  • P.-H. Lin, yes it does. Even with all the restrictions and proxies on the network at school, my laptop still has no trouble accessing the internet on Ubuntu. – iqover9000 Oct 15 '14 at 23:00
0

This worked for me, I have the same wifi adapter. Copy/Paste the following in a terminal and reboot. You have to re-"make" after every kernel update, to ensure best performance.

sudo apt-get install --reinstall linux-headers-generic linux-headers-$(uname -r) build-essential dkms git

git clone https://github.com/FreedomBen/rtl8188ce-linux-driver

cd rtl8188ce-linux-driver

make

sudo make install

sudo cp -r firmware/* /lib/firmware

echo "options rtl8188ee ips=0 fwlps=0" | sudo tee /etc/modprobe.d/rtl8188ee.conf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.