2

Ok, so in hind sight purging a package that was marked as a critical package was probably a terrible idea, but I was only following the instructions of people from this thread.

I couldn't get default-jre to install (it complained about broken packages), so after a bit of googling I came across the article above. I typed the command sudo apt-get remove --purge tzdata and hit enter. Then it warned me tzdata was a critical package. I hesitated, obviously, and tried to find more information on the package but could find almost nothing. I assumed it was some non-essential part of Lubuntu but was marked as critical simply because it was a system program (also, my fears were mostly abated by the exceptionally casual nature with which the posters in that other thread instructed the OP to purge his tzdata).

So I typed the phrase and hit enter, and.... it started removing EVERYTHING. All the stuff I had set up, was being removed. Then, as I was doing it over VNC and the VNC died, I ran to the physical screen. It was quickly crashing because my keep-the-vnc-going scripts were layering onto of each other and exponentially increasing in number. So with the GUI completely unresponsive (I waited five minutes and nothing would happen except more scripts occasionally appeared), I hit the reset button on the PC.

It didn't boot into Lubuntu but memtest(x86) for some reason.

So this is where we are right now. I'm asking for help on fixing it, because ideally I don't want to reinstall, but since I began writing the question I've realised I should actually just be able to extract my scripts and some config files and reinstall Lubuntu, as it's just a NAS with very little software installed.

How would you suggest I proceed?

2

You could spend hours trying to recover your Lubuntu system with no guarantee of success or you can just reinstall in a half hour and know that that will work. Save any files that you don't have backups for onto a thumb drive or similar and in future note what apt is telling you it will remove. To save files, boot into a live session, like with the default Ubuntu disc, mount your partition that contains /home and copy your files out of there onto a thumb drive. Then reinstall.

  • 2
    Yup, that's what we decided to do. The OS is actually installed on an 8GB flash key, so we just plugged it into my sister's laptop (which has Lubuntu dual-booting with Windows for faster Minecrafting) and copied the entire flash key to her desktop. Lesson learned, definitely gonna watch what apt is saying it'll remove next time (actually not sure why I ignored it - not the sort of thing I skim over normally). Still entirely confused as to why those people suggested apt-get removeing tzdata in that other thread. Seems like a really dumb idea. – Clonkex Oct 14 '14 at 6:42
  • 1
    Yeah, following random Internet advice is usually ok but every once in a while you run into some bad bad advice. – headkase Oct 14 '14 at 7:32
  • Apparently! And I'm a programmer and an IT expert (I dare not say 'professional' after this mistake) so you'd think I'd know better... *facedesk* It's all good now, though. Just in the process of installing GCC so I can compile SnapRAID and install it. Just about everything else is reinstalled already. Right now I'm trying to remember how I had the clock set up :P – Clonkex Oct 14 '14 at 8:06
  • In fact, after this, I intend to keep a backup of the OS on my main PC since it's only about 3GB total size (which, after years of using Windows, is ridiculously small!) and kept on a flash key (so I only need turn off the Lubuntu PC and carry the flash key to my main PC). – Clonkex Oct 14 '14 at 8:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.